Last Comment Bug 778322 - Remove the prefetch deleted registry key from machines that contain it
: Remove the prefetch deleted registry key from machines that contain it
Status: VERIFIED FIXED
[qa!]
:
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: Trunk
: All Windows 7
: -- normal (vote)
: mozilla17
Assigned To: Nobody; OK to take it and work on it
: Jason Smith [:jsmith]
: Jim Mathies [:jimm]
Mentors:
Depends on:
Blocks: 692255
  Show dependency treegraph
 
Reported: 2012-07-27 15:32 PDT by Jason Smith [:jsmith]
Modified: 2012-08-27 13:23 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1. (1.81 KB, patch)
2012-07-31 15:42 PDT, Brian R. Bondy [:bbondy]
jmathies: review+
Details | Diff | Splinter Review

Description Jason Smith [:jsmith] 2012-07-27 15:32:14 PDT
We are no longer clearing prefetch files anymore, but the registry key still exists in the Windows registry. We should clean up after ourselves and get rid of that registry key if we detect it.
Comment 1 Brian R. Bondy [:bbondy] 2012-07-27 18:52:35 PDT
I'm not disputing the validity of this task, but just wanted to add a note that the uninstaller will get rid of it.
Comment 2 Brian R. Bondy [:bbondy] 2012-07-31 15:41:03 PDT
Actually I was wrong in Comment 1, I tested this out and since the Attempted reg value needs to exist which is alongside the ffdeletedprefetch registry value, the whole key folder isn't removed.
Comment 3 Brian R. Bondy [:bbondy] 2012-07-31 15:42:55 PDT
Created attachment 647726 [details] [diff] [review]
Patch v1.

This is just a simple cleanup task with a reg value that is no longer used.
The service installer is run on each update so it will get rid of the reg key on the next update.  It's also added to the uninstall section of the maintenance service in case someone doesn't get an update but uninstalls instead.
Comment 4 Brian R. Bondy [:bbondy] 2012-08-01 12:01:40 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/66985ff899e2
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-08-01 19:40:47 PDT
https://hg.mozilla.org/mozilla-central/rev/66985ff899e2

Note You need to log in before you can comment on or make changes to this bug.