Test users should be able to flash their devices without losing personal data

RESOLVED DUPLICATE of bug 778084

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 778084
5 years ago
5 years ago

People

(Reporter: akeybl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [B2GTest:Blocker])

(Reporter)

Description

5 years ago
Test users should be able to Flash their devices without losing personal data.
(Reporter)

Comment 1

5 years ago
s/Flash/flash/, force of habit.
Summary: Test users should be able to Flash their devices without losing personal data → Test users should be able to flash their devices without losing personal data
We get this property for free by how we package the FOTA update.  If it doesn't include files to overwrite the data, and doesn't explicitly delete it or reformat the fs, then the data isn't touched.

There's no additional client- or server-side support needed for this, beyond correctly creating update packages.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 778084
Note, this is not unlike Firefox update packages.
But rereading this I wonder if you mean USB flashing, i.e. |./flash.sh| in a b2g checkout?

If so, this should be filed in https://github.com/mozilla-b2g/b2g .
(Reporter)

Comment 5

5 years ago
(In reply to Chris Jones [:cjones] [:warhammer] from comment #4)
> But rereading this I wonder if you mean USB flashing, i.e. |./flash.sh| in a
> b2g checkout?
> 
> If so, this should be filed in https://github.com/mozilla-b2g/b2g .

Correct, this was not in reference to FOTA. That was in 778336 (and may be a RelEng bug?).

I'll file this one on github.
Thanks!

Fwiw this is very easy to do, but it's relatively unsafe in general.
(In reply to Chris Jones [:cjones] [:warhammer] from comment #6)
> Thanks!
> 
> Fwiw this is very easy to do, but it's relatively unsafe in general.

Can you clarify what you mean by unsafe? Because of upgrade/downgrade concerns in files/formats in the profile?
Yes, mainly.
Aren't we going to be doing basically this exact thing day in/out as soon as humanly possible w/ nightly build updates? We need to flex software update of gecko/gaia as much as we can before shipping.
Yes ... the same caveat applies there.

We need to either decide that there are DB / format changes for which we may not do all the (sometimes quite substantial) work of upgrade/downgrade, before release, because of limited engineering resources --- meaning dogfooding users can lose data --- or we make backwards/forwards compat a requirement for shipping dogfooding builds.

Obviously the latter sounds better, but I hate to commit to it.

Another option is a fast-restore system for unstable users, not production quality.  As a dev working across many phones I would find that useful anyway.

I think it's worth polling the devs of DB-backed APIs (contacts, apps, alarms, ... I think a few more) to see whether there are schema changes on the horizon, and what this burden implies.
(Reporter)

Comment 11

5 years ago
(In reply to Chris Jones [:cjones] [:warhammer] from comment #10)
> I think it's worth polling the devs of DB-backed APIs (contacts, apps,
> alarms, ... I think a few more) to see whether there are schema changes on
> the horizon, and what this burden implies.

We can bring this up during today's B2G sync-up.
You need to log in before you can comment on or make changes to this bug.