Closed Bug 778425 Opened 8 years ago Closed 7 years ago

Unable to view crash queries with a signature containing ++

Categories

(Socorro :: Webapp, task)

task
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: scoobidiver, Assigned: adrian)

References

Details

Assignee: nobody → adrian
Target Milestone: --- → 19
Pull request: https://github.com/mozilla/socorro/pull/757

The "+" symbol is a special one in the middleware, and was used as a separator for lists. It is now double-encoded in signatures to make sure that we don't break it. 

Steps to QA
-----------

1. Go to advanced search and search for crashes in FennecAndroid with signature containing "libstdc";
2. Click one of the signatures to go to report/list;
3. Verify that you get results and numbers are matching those from search;
4. Verify that each tab has data;
5. Verify that report/list is not broken for other signatures (use topcrashers for example);
6. Enjoy a little M&M's.
Duplicate of this bug: 780809
Is it planned to land?
Yes, in release 19 which will come one week after we ship the special mobeta release (18). No date though as 18 will be release "when it's ready". https://wiki.mozilla.org/Socorro:Releases will be updated when we have release dates.
Commits pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/cc4114924d4e82047c60531b10bb2e7751d254bc
Fixes bug 778425 - Double-encode pluses in signature before HTTP GET requests.

https://github.com/mozilla/socorro/commit/a09451d5d04b82370df917a0f3575d163498fbbb
Merge pull request #764 from AdrianGaudebert/778425-fix-plus-in-signature

Fixes bug 778425 - Double-encode pluses in signature before HTTP GET req...
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.