Last Comment Bug 778496 - Layer should store ComputedTimingFunction directly rather than as a pointer
: Layer should store ComputedTimingFunction directly rather than as a pointer
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics: Layers (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla17
Assigned To: David Zbarsky (:dzbarsky)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-28 16:35 PDT by David Zbarsky (:dzbarsky)
Modified: 2012-07-30 02:44 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (3.62 KB, patch)
2012-07-28 16:36 PDT, David Zbarsky (:dzbarsky)
roc: review+
Details | Diff | Splinter Review

Description David Zbarsky (:dzbarsky) 2012-07-28 16:35:01 PDT

    
Comment 1 David Zbarsky (:dzbarsky) 2012-07-28 16:36:29 PDT
Created attachment 646926 [details] [diff] [review]
Patch
Comment 2 David Zbarsky (:dzbarsky) 2012-07-28 16:37:35 PDT
This was previously impossible because Layers.h was included in nsIWidget.h, but I have since cleaned it up.
Comment 3 David Zbarsky (:dzbarsky) 2012-07-29 19:00:25 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/ffc57e09995e
Comment 4 Ed Morley [:emorley] 2012-07-30 02:44:02 PDT
https://hg.mozilla.org/mozilla-central/rev/ffc57e09995e

Note You need to log in before you can comment on or make changes to this bug.