Last Comment Bug 778595 - [Azure] Add a reftest sandbox flag for a mismatch between Azure backends
: [Azure] Add a reftest sandbox flag for a mismatch between Azure backends
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: 15 Branch
: x86_64 Windows 7
: -- normal (vote)
: mozilla17
Assigned To: Nick Cameron [:nrc]
:
Mentors:
Depends on: 776802
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-29 17:12 PDT by Nick Cameron [:nrc]
Modified: 2012-08-01 19:40 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.32 KB, patch)
2012-07-29 20:38 PDT, Nick Cameron [:nrc]
no flags Details | Diff | Review
patch (1.34 KB, patch)
2012-07-29 22:42 PDT, Nick Cameron [:nrc]
roc: review+
Details | Diff | Review
patch (1.46 KB, patch)
2012-07-30 14:20 PDT, Nick Cameron [:nrc]
ncameron: review+
Details | Diff | Review

Description Nick Cameron [:nrc] 2012-07-29 17:12:08 PDT
We would like to be able to add fuzz to tests if canvas and content are rendered using different backends.
Comment 1 Nick Cameron [:nrc] 2012-07-29 20:38:58 PDT
Created attachment 647048 [details] [diff] [review]
patch
Comment 2 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-07-29 21:00:00 PDT
Comment on attachment 647048 [details] [diff] [review]
patch

Review of attachment 647048 [details] [diff] [review]:
-----------------------------------------------------------------

::: layout/tools/reftest/reftest.js
@@ +489,5 @@
>      sandbox.azureQuartz = gfxInfo.getInfo().AzureCanvasBackend == "quartz";
>      sandbox.azureSkia = gfxInfo.getInfo().AzureCanvasBackend == "skia";
> +    // true if we are using a different Azure backend for rendering canvas and content
> +    sandbox.azureMismatch = gfxInfo.getInfo().AzureContentBackend != gfxInfo.getInfo().AzureCanvasBackend
> +                            && !(gfxInfo.getInfo().AzureContentBackend == "none" && gfxInfo.getInfo().AzureCanvasBackend == "cairo");

How about "sandbox.contentSameGfxBackendAsCanvas"?
Comment 3 Nick Cameron [:nrc] 2012-07-29 22:42:15 PDT
Created attachment 647069 [details] [diff] [review]
patch

changed the name of the flag
Comment 4 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-07-30 01:39:19 PDT
Comment on attachment 647069 [details] [diff] [review]
patch

Review of attachment 647069 [details] [diff] [review]:
-----------------------------------------------------------------

Hoist gfxInfo.getInfo() into a local variable, eh?
Comment 5 Nick Cameron [:nrc] 2012-07-30 14:20:19 PDT
Created attachment 647298 [details] [diff] [review]
patch

hoisted gfxInfo.GetInfo(), carrying r=roc
Comment 7 Nick Cameron [:nrc] 2012-07-30 23:22:48 PDT
backed out: https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=cda1c40da986
Comment 9 Ryan VanderMeulen [:RyanVM] 2012-08-01 19:40:01 PDT
https://hg.mozilla.org/mozilla-central/rev/ce9bc8ec663d

Note You need to log in before you can comment on or make changes to this bug.