Last Comment Bug 778666 - crash in DocAccessible::DocAccessible
: crash in DocAccessible::DocAccessible
Status: RESOLVED FIXED
: crash, regression
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: 17 Branch
: All Linux
: -- critical (vote)
: mozilla17
Assigned To: Trevor Saunders (:tbsaunde)
:
Mentors:
: 779063 (view as bug list)
Depends on:
Blocks: 765252
  Show dependency treegraph
 
Reported: 2012-07-30 02:23 PDT by Scoobidiver (away)
Modified: 2012-08-02 02:22 PDT (History)
3 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.00 KB, patch)
2012-07-30 09:20 PDT, Trevor Saunders (:tbsaunde)
surkov.alexander: review+
Details | Diff | Splinter Review

Description Scoobidiver (away) 2012-07-30 02:23:12 PDT
It first appeared in 17.0a1/20120729. The regression window is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2abd21593e57&tochange=29bff59d3bbe
It's likely a regression from bug 765252.

Signature 	DocAccessible::DocAccessible More Reports Search
UUID	57e155d5-6c63-4b06-bd68-07c302120730
Date Processed	2012-07-30 08:16:47
Uptime	22
Last Crash	27 seconds before submission
Install Age	18.4 minutes since version was first installed.
Install Time	2012-07-30 07:58:16
Product	Firefox
Version	17.0a1
Build ID	20120729030516
Release Channel	nightly
OS	Linux
OS Version	0.0.0 Linux 3.5.0-6-generic #6-Ubuntu SMP Mon Jul 23 19:52:14 UTC 2012 x86_64
Build Architecture	amd64
Build Architecture Info	family 15 model 6 stepping 5
Crash Reason	SIGSEGV
Crash Address	0x50
App Notes 	
OpenGL: NVIDIA Corporation -- GeForce 7600 GT/PCIe/SSE2 -- 2.1.2 NVIDIA 304.22 -- texture_from_pixmap
EMCheckCompatibility	True

Frame 	Module 	Signature 	Source
0 	libxul.so 	DocAccessible::DocAccessible 	nsIPresShell.h:282
1 	libxul.so 	DocAccessibleWrap::DocAccessibleWrap 	accessible/src/atk/DocAccessibleWrap.cpp:17
2 	libxul.so 	mozilla::a11y::RootAccessible::RootAccessible 	accessible/src/generic/RootAccessible.cpp:73
3 	libxul.so 	mozilla::a11y::NativeRootAccessibleWrap::NativeRootAccessibleWrap 	accessible/src/atk/RootAccessibleWrap.cpp:14
4 	libxul.so 	nsAccessibilityService::AddNativeRootAccessible 	accessible/src/base/nsAccessibilityService.cpp:1676
5 	libxul.so 	toplevel_event_watcher 	accessible/src/atk/ApplicationAccessibleWrap.cpp:554
6 	libgobject-2.0.so.0.3306.0 	signal_emit_unlocked_R 	gsignal.c:3517
7 	libgobject-2.0.so.0.3306.0 	g_signal_emit_valist 	gsignal.c:3300
8 	libgobject-2.0.so.0.3306.0 	g_signal_emit 	gsignal.c:3356
9 	libgtk-x11-2.0.so.0.2400.11 	IA__gtk_widget_show 	gtkwidget.c:3218
10 	libgtk-x11-2.0.so.0.2400.11 	IA__gtk_dialog_run 	gtkdialog.c:1065
11 	libxul.so 	nsFilePicker::Show 	widget/gtk2/nsFilePicker.cpp:478
12 	libxul.so 	NS_InvokeByIndex_P 	xptcinvoke_x86_64_unix.cpp:164
13 	libxul.so 	XPCWrappedNative::CallMethod 	js/xpconnect/src/XPCWrappedNative.cpp:3082
14 	libxul.so 	XPC_WN_CallMethod 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp:1474
15 	libxul.so 	js::InvokeKernel 	js/src/jscntxtinlines.h:387
16 	libxul.so 	js::Interpret 	js/src/jsinterp.cpp:2405
...

More reports at:
https://crash-stats.mozilla.com/report/list?signature=DocAccessible%3A%3ADocAccessible
Comment 1 Trevor Saunders (:tbsaunde) 2012-07-30 09:20:26 PDT
Created attachment 647199 [details] [diff] [review]
patch

this is just another case of NativeRootAccessibles are DocAccessibles but have no content / document / pres shell
Comment 2 alexander :surkov 2012-07-31 02:34:33 PDT
Comment on attachment 647199 [details] [diff] [review]
patch

Review of attachment 647199 [details] [diff] [review]:
-----------------------------------------------------------------

these native documents shouldn't be instances of DocAccessible really
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-07-31 19:18:23 PDT
https://hg.mozilla.org/mozilla-central/rev/b6921f1d2035
Comment 4 Scoobidiver (away) 2012-08-02 02:22:30 PDT
*** Bug 779063 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.