Last Comment Bug 778695 - Intermittent 328829-2.xhtml | image comparison (==)
: Intermittent 328829-2.xhtml | image comparison (==)
Status: RESOLVED FIXED
[qa-]
: intermittent-failure
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: mozilla19
Assigned To: Nathan Froyd [:froydnj]
:
:
Mentors:
Depends on:
Blocks: 438871
  Show dependency treegraph
 
Reported: 2012-07-30 04:31 PDT by Ed Morley [:emorley]
Modified: 2012-11-25 19:31 PST (History)
2 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
fixed
fixed


Attachments
patch (1.52 KB, patch)
2012-10-27 17:02 PDT, Nathan Froyd [:froydnj]
dholbert: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2012-07-30 04:31:26 PDT
Rev3 WINNT 5.1 mozilla-inbound opt test reftest on 2012-07-27 22:22:07 PDT for push b5b442d9c305

slave: talos-r3-xp-042

https://tbpl.mozilla.org/php/getParsedLog.php?id=13930908&tree=Mozilla-Inbound

{
REFTEST TEST-START | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/bugs/328829-2.xhtml | 1642 / 8066 (20%)
REFTEST TEST-START | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/bugs/328829-2-ref.xhtml | 1642 / 8066 (20%)
REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/bugs/328829-2.xhtml | image comparison (==)
REFTEST max difference: 255 number of differing pixels: 711
}
Comment 1 Treeherder Robot 2012-08-10 11:01:41 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=14298012&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound opt test reftest on 2012-08-10 10:22:35
slave: talos-r3-xp-069

REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/bugs/328829-2.xhtml | image comparison (==)
Comment 2 Treeherder Robot 2012-08-20 17:17:55 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=14541606&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound opt test reftest on 2012-08-20 16:23:23
slave: talos-r3-xp-022

REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/bugs/328829-2.xhtml | image comparison (==)
Comment 3 Treeherder Robot 2012-10-24 16:20:21 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=16423573&tree=Profiling
Rev3 WINNT 5.1 profiling opt test reftest on 2012-10-24 11:17:08
slave: talos-r3-xp-018

REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/reftest/tests/layout/reftests/bugs/328829-2.xhtml | image comparison (==), max difference: 255, number of differing pixels: 711
Comment 4 Nathan Froyd [:froydnj] 2012-10-27 17:02:15 PDT
Created attachment 675905 [details] [diff] [review]
patch

As discussed on IRC, this should be using reftest-wait.
Comment 5 Daniel Holbert [:dholbert] 2012-10-27 17:44:51 PDT
Comment on attachment 675905 [details] [diff] [review]
patch

># HG changeset patch
># User Nathan Froyd <froydnj@gmail.com>
>
>fix layout/reftests/bugs/328829-2.xhtml intermittent orange by using MozReftestInvalidate

Nit: checkin message should also mention "reftest-wait", since that's the part that's actually going to fix the intermittent failure, presumably.

r=me with that
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-10-28 14:03:12 PDT
https://hg.mozilla.org/mozilla-central/rev/9e3d4423e37f

Note You need to log in before you can comment on or make changes to this bug.