Fatal "compartment mismatched" assertion trying to use Add-on Builder Helper in Nightly

RESOLVED DUPLICATE of bug 778409

Status

()

Core
XPConnect
--
critical
RESOLVED DUPLICATE of bug 778409
6 years ago
6 years ago

People

(Reporter: jwatt, Unassigned)

Tracking

({crash})

Trunk
x86
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

It seems that if you try and use Add-on Builder Helper - or any of the many add-ons that depend on it - in debug Nightly, it will crash due to a fatal "compartment mismatched" assertion. With that add-on (and only that add-on) enabled, crashing is pretty much just a page load away.

This is a pretty major pain in the neck, since I now can't use a lot of the add-ons that I depend on for debugging.
Jonathan, do you have a stack to the assert point?
Created attachment 647204 [details]
stack

Not hard to get.
Thanks.  This is totally xpconnect.  ;)
Assignee: general → nobody
Component: JavaScript Engine → XPConnect
Okay. I'll un-CC David then, since I'm sure he get's CC'ed on enough bugs.
This is bug 778409 - Has a patch, just needs review.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 778409
You need to log in before you can comment on or make changes to this bug.