compartment mismatched during reading-data/test-main.js

RESOLVED DUPLICATE of bug 778409

Status

RESOLVED DUPLICATE of bug 778409
6 years ago
6 years ago

People

(Reporter: ochameau, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

We are failing tests on all platforms in debug builds:
https://tbpl.mozilla.org/php/getParsedLog.php?id=13967773&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=13967099&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=13969655&tree=Mozilla-Inbound

Here is a stacktrace:
001290e0 00a08ace mozjs!js::CompartmentChecker::fail+0x2d [c:\projects\debug\js\src\jscntxtinlines.h @ 227]
00129100 02388ff6 mozjs!JS_IdentifyClassPrototype+0xde [c:\projects\debug\js\src\jsapi.cpp @ 2234]
001291b4 00a5b976 xul!xpc::WrapperFactory::Rewrap+0x2b6 [c:\projects\debug\js\xpconnect\wrappers\wrapperfactory.cpp @ 407]
00129228 00a5714e mozjs!JSCompartment::wrap+0x506 [c:\projects\debug\js\src\jscompartment.cpp @ 281]
0012924c 009eeca4 mozjs!JSCompartment::wrap+0x2e [c:\projects\debug\js\src\jscompartment.cpp @ 323]
00129260 02381d13 mozjs!JS_WrapObject+0x24 [c:\projects\debug\js\src\jsapi.cpp @ 1561]
001292c0 02381dcc xul!xpc::XrayUtils::LookupExpandoObject+0x2b [c:\projects\debug\js\xpconnect\wrappers\xraywrapper.cpp @ 137]
001292e4 023871b7 xul!xpc::XrayUtils::LookupExpandoObject+0x58 [c:\projects\debug\js\xpconnect\wrappers\xraywrapper.cpp @ 161]
00129354 02387cc8 xul!xpc::XPCWrappedNativeXrayTraits::resolveOwnProperty+0x157 [c:\projects\debug\js\xpconnect\wrappers\xraywrapper.cpp @ 819]
001293dc 00b57c32 xul!xpc::XrayWrapper<js::CrossCompartmentWrapper,xpc::XPCWrappedNativeXrayTraits>::getPropertyDescriptor+0x1a6 [c:\projects\debug\js\xpconnect\wrappers\xraywrapper.cpp @ 1288]
00129448 02382750 mozjs!js::BaseProxyHandler::get+0xb2 [c:\projects\debug\js\src\jsproxy.cpp @ 104]
00129464 00b54cc8 xul!xpc::XrayWrapper<js::CrossCompartmentWrapper,xpc::XPCWrappedNativeXrayTraits>::get+0x18 [c:\projects\debug\js\xpconnect\wrappers\xraywrapper.cpp @ 1497]
00129498 00b55853 mozjs!js::Proxy::get+0x68 [c:\projects\debug\js\src\jsproxy.cpp @ 1117]
001294b8 009fb8c1 mozjs!js::Proxy::iteratorNext+0x2e3 [c:\projects\debug\js\src\jsproxy.cpp @ 1335]
001294d8 00ae5522 mozjs!JSObject::getGeneric+0x31 [c:\projects\debug\js\src\jsobjinlines.h @ 174]
001294f0 00aec84f mozjs!js::GetPropertyGenericMaybeCallXML+0x62 [c:\projects\debug\js\src\jsinterpinlines.h @ 203]
0012953c 00af0157 mozjs!js::GetPropertyOperation+0x2af [c:\projects\debug\js\src\jsinterpinlines.h @ 266]
00129958 00ae99ab mozjs!js::Interpret+0x2697 [c:\projects\debug\js\src\jsinterp.cpp @ 2302]
0012999c 00aed408 mozjs!js::RunScript+0x3eb [c:\projects\debug\js\src\jsinterp.cpp @ 302]
001299e4 00a2285d mozjs!js::InvokeKernel+0x398 [c:\projects\debug\js\src\jsinterp.cpp @ 359]

It seems to fail during the execution of following JS code:
https://github.com/mozilla/addon-sdk/blob/master/examples/reading-data/tests/test-main.js#L15
Which call this method:
https://github.com/mozilla/addon-sdk/blob/master/examples/reading-data/lib/main.js#L14
I have to go now but will try to look into this tomorrow. CC-ed bholley because of the compartment mismatched error.
Apologies in advance if this double posts (I already submitted this once, but it never showed up here. Given how my day's been going, the original post will appear after I re-submit it...)


Anyway, the first time I see this is in this push: https://tbpl.mozilla.org/?noignore=1&jobname=jetpack&rev=82b6c5885345
This is bug 778409. Have a patch, just waiting for review.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 778409
You need to log in before you can comment on or make changes to this bug.