CSS attributes on <input type=file> have no effect

RESOLVED DUPLICATE of bug 52500

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 52500
17 years ago
17 years ago

People

(Reporter: Shawn, Assigned: Pierre Saslawsky)

Tracking

({qawanted})

Trunk
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
If you go to the above URL, the CSS attributes applied to all the input and
select boxes on that page work fine, except on <input type=file>.  The CSS
attributes used are:

a {
	text-decoration: none;
}
a:hover {
	text-decoration: underline;
}
body {
	scrollbar-3d-light-color:#f2ddab;
	scrollbar-arrow-color:#000000;
	scrollbar-base-color: #f2ddab;
}
layer,span,div,td,input,select,textarea {
	font-family: verdana,arial,helvetica;
	font-size: 8pt;
}

This is a separate CSS file called by a <LINK REL=STYLESHEET>.

Comment 1

17 years ago
If I understand the report correctly (the relevant part), mozilla renders the
other form controls with a 8pt verdana, while input[type="file"] is not styled.

The problem here is that mozilla does not style for input[type="file"] controls.

This is a style issue and should probably be marked as a dupe of bug 52500.
Assignee: karnaze → pierre
Component: Layout → Style System
Depends on: 52500
QA Contact: petersen → ian
Summary: CSS attributes on <input type=file> don't work. → [dupe?]CSS attributes on <input type=file> don't work.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
OS: Windows 98 → All
Hardware: PC → All

Comment 2

17 years ago
Shawn, do you agree that this bug is covered by bug 52500? Thank you for your
answer.
Whiteboard: DUPEME
(Reporter)

Comment 3

17 years ago
No, because that bug is about wacked styling.  This bug is about no styling 
whatsoever.  In the testcases for the other bug, the styling looked funny, but 
at least it <i>was</i> styled.  In this bug, it appears as though it's 
completely ignoring all style information for type "input" if it applies to 
type=file.  Just my $0.02.

Comment 4

17 years ago
removing DUPEME, minor change to summary
Summary: [dupe?]CSS attributes on <input type=file> don't work. → CSS attributes on <input type=file> have no effect
Whiteboard: DUPEME

Comment 5

17 years ago
I'm having the same problems on 2001080600-rpm on Linux RH7.1.

CSS applied to the <input type="file" class="inputText"> doesn't not affect this
tag.  The style.css file has the following styling for inputText:

.inputText {
        font-family: Arial, Helvetica, Lucida, sans-serif; color: #000000;
        font-size: 12px; font-weight: normal; text-decoration: none;
}

Comment 6

17 years ago
THis is a dupe of bug 52500.  Bug 52500 orginally was filed because file input
had wack styling with some properties but with more investigation you can see
that other css properties are completely ignored.

My bug report 52813 I duped for this same reason.  File input styling is broken.
See the testcase
(http://bugzilla.mozilla.org/showattachment.cgi?attach_id=12896) to prove my point.
Why should we have many different reports dealing with the same issue -- Styling
for file inputs is messed up.  

With your logic there should be one report for each property ignored (I could
come up with probably easily 10 new reports)? Personally, I think it would be
more productive for the Pierre to have one report that has a list of all
properties wonked. My $.02.
(Assignee)

Comment 7

17 years ago
It sure is a dup.  Thanks James.


*** This bug has been marked as a duplicate of 52500 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.