Pre-install the Marketplace webapp

RESOLVED DUPLICATE of bug 741621

Status

()

Firefox for Android
Web Apps
P1
normal
RESOLVED DUPLICATE of bug 741621
5 years ago
5 years ago

People

(Reporter: mfinkle, Assigned: wesj)

Tracking

16 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

We want built-in support for the Marketplace webapp. Users should not need to go and install it themselves. The webapp is hosted, so we only need a minimal set of things to happen to pre-install it, mainly include a manifest in the APK.

I don't know if we can do everything needed to pre-install the Marketplace app without running Firefox first. If we can't, we could add a simple "installMarketplace" function for new non-webapp profiles. This might be a good thing to do anyway, if users will be able to create multiple browsing profiles.

Updated

5 years ago
Blocks: 766259
Whiteboard: [blocking-webrtandroid1+]

Updated

5 years ago
OS: Linux → Android
Hardware: x86_64 → ARM
We need to determine if we want a specific WebApp# set aside for the Marketplace, maybe WebAppMarketplace ?

Also, maybe we can "install on demand" if we can cover the entry points: marketplace URL intent, about:home snippet, etc. If we could "install on demand" it would remove some code from our startup path.

Updated

5 years ago
Priority: -- → P1
(Assignee)

Comment 2

5 years ago
Created attachment 648175 [details] [diff] [review]
Part 1

This installs the marketplace webapp the first time you visit about apps. The install prompt can take its time to show up because its hitting the network. We might be better showing a doorhanger and then (somehow) suppressing the normal prompt later?

How do you feel about just pulling this from the server?
Assignee: nobody → wjohnston
Attachment #648175 - Flags: feedback?(mark.finkle)
(Assignee)

Comment 3

5 years ago
Comment on attachment 648175 [details] [diff] [review]
Part 1

Removing feedback. I'm putting in some better infrastructure in the "Open market links in the market" bug.
Attachment #648175 - Flags: feedback?(mark.finkle)
(Assignee)

Comment 4

5 years ago
I think what we really want here is what I have in bug 741621. There we have code to show the Marketplace in the list of registered apps when the user visits a marketplace url (i.e. even if you open one in the stock browser, the user will see a "Open in" prompt with the marketplace listed. Selecting it will install and launch it with no prompting).

If the user visits the marketplace in Fennec, we show a doorhanger offering to use the webapp which also does a silent install and launch. From the users perspective it is "installed" without us throwing icons on their launch screen without asking.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 741621
(Assignee)

Updated

5 years ago
Whiteboard: [blocking-webrtandroid1+]
You need to log in before you can comment on or make changes to this bug.