Camera - generate shutter events

RESOLVED DUPLICATE of bug 779145

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 779145
6 years ago
5 years ago

People

(Reporter: mikeh, Assigned: mikeh)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [LOE:S])

There is a single instance of the camera hardware in B2G, and it is always given to the latest camera control-using app.

Need to provide an event handler so that the current app knows when a newer one has come along and grabbed the camera.
Summary: [b2g] Camera - notify app when a newer app takes over the camera → Camera - notify app when a newer app takes over the camera
Status: NEW → ASSIGNED
Summary: Camera - notify app when a newer app takes over the camera → Camera - generate shutter events and notify app when a newer app takes over the camera
blocking-basecamp: --- → ?
Whiteboard: [LOE:S]
I believe we want to support multiple camera apps.
blocking-basecamp: ? → +
We can't give multiple camera apps raw access to the stream because of the OS privileges problem, so we don't need to handle that case.

Mike tells me this work is all the same stuff, but refocusing for what we want for v1.
Summary: Camera - generate shutter events and notify app when a newer app takes over the camera → Camera - generate shutter events
The work for this issue was bundled into the patch for bug 779145, which landed on the weekend.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 779145
You need to log in before you can comment on or make changes to this bug.