Last Comment Bug 779217 - Intermittent test_outgoing_hangup_held.js: got OK, expected outbound to 5555552368 : unknown | got false, expected true
: Intermittent test_outgoing_hangup_held.js: got OK, expected outbound to 55555...
Status: RESOLVED FIXED
: intermittent-failure
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: Hsin-Yi Tsai [:hsinyi]
:
:
Mentors:
Depends on:
Blocks: 438871
  Show dependency treegraph
 
Reported: 2012-07-31 10:56 PDT by Jonathan Griffin (:jgriffin)
Modified: 2012-11-25 19:31 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (2.24 KB, patch)
2012-08-02 21:14 PDT, Hsin-Yi Tsai [:hsinyi]
no flags Details | Diff | Splinter Review
Patch (2.26 KB, patch)
2012-08-02 21:35 PDT, Hsin-Yi Tsai [:hsinyi]
philipp: review+
Details | Diff | Splinter Review

Description Jonathan Griffin (:jgriffin) 2012-07-31 10:56:23 PDT
The Marionette WebAPI test test_outgoing_hangup_held.js sometimes fails with the error:

test_outgoing_hangup_held.js
TEST-UNEXPECTED-FAIL | Traceback (most recent call last):
File "/data/jenkins/workspace/webapi-marionette-test/testing/marionette/client/marionette/marionette_test.py", line 194, in runTest
'%d tests failed:\n%s' % (results['failed'], '\n'.join(fails)))
AssertionError: 2 tests failed:
TEST-UNEXPECTED-FAIL | got OK, expected outbound to 5555552368 : unknown | got false, expected true
TEST-UNEXPECTED-FAIL | got undefined, expected OK | got false, expected true

The log shows:

START LOG:
INFO Verifying initial state. Tue Jul 31 2012 02:36:20 GMT+0000 (GMT)
INFO Initial call list: OK Tue Jul 31 2012 02:36:20 GMT+0000 (GMT)
INFO Make an outgoing call. Tue Jul 31 2012 02:36:20 GMT+0000 (GMT)
INFO Call list is now: OK Tue Jul 31 2012 02:36:20 GMT+0000 (GMT)
INFO Answering the outgoing call. Tue Jul 31 2012 02:36:20 GMT+0000 (GMT)
INFO Received 'connected' call event. Tue Jul 31 2012 02:36:20 GMT+0000 (GMT)
INFO Call list is now: outbound to  5555552368 : active,OK Tue Jul 31 2012 02:36:20 GMT+0000 (GMT)
INFO Holding the outgoing call. Tue Jul 31 2012 02:36:20 GMT+0000 (GMT)
INFO Received 'holding' call event. Tue Jul 31 2012 02:36:20 GMT+0000 (GMT)
INFO Received 'held' call event. Tue Jul 31 2012 02:36:20 GMT+0000 (GMT)
INFO Call list is now: outbound to  5555552368 : held,OK Tue Jul 31 2012 02:36:20 GMT+0000 (GMT)
INFO Hanging up the outgoing call. Tue Jul 31 2012 02:36:20 GMT+0000 (GMT)
INFO Received disconnecting call event. Tue Jul 31 2012 02:36:20 GMT+0000 (GMT)
INFO Received 'disconnected' call event. Tue Jul 31 2012 02:36:20 GMT+0000 (GMT)
INFO Call list is now: OK Tue Jul 31 2012 02:36:20 GMT+0000 (GMT)
END LOG:
Comment 1 Hsin-Yi Tsai [:hsinyi] 2012-08-02 21:14:39 PDT
Created attachment 648603 [details] [diff] [review]
Patch

Consolidate test_outgoing_hangup_held.js
Comment 2 Hsin-Yi Tsai [:hsinyi] 2012-08-02 21:26:19 PDT
(In reply to Jonathan Griffin (:jgriffin) from comment #0)
> The Marionette WebAPI test test_outgoing_hangup_held.js sometimes fails with
> the error:
> 
> test_outgoing_hangup_held.js
> TEST-UNEXPECTED-FAIL | Traceback (most recent call last):
> File
> "/data/jenkins/workspace/webapi-marionette-test/testing/marionette/client/
> marionette/marionette_test.py", line 194, in runTest
> '%d tests failed:\n%s' % (results['failed'], '\n'.join(fails)))
> AssertionError: 2 tests failed:
> TEST-UNEXPECTED-FAIL | got OK, expected outbound to 5555552368 : unknown |
> got false, expected true
> TEST-UNEXPECTED-FAIL | got undefined, expected OK | got false, expected true
> 
According to the log, when requesting "gsm list", we only got "OK", instead of "outbound to 5555552368 : unknown". I did not encounter this test failure actually. That means emulator hasn't established the dialling call but we thought the emulator had. So, we need to make sure there *is* a call ready for answer(). That's what attachment 648603 [details] [diff] [review] attempts to do. Thanks!
Comment 3 Hsin-Yi Tsai [:hsinyi] 2012-08-02 21:35:35 PDT
Created attachment 648608 [details] [diff] [review]
Patch

Updated patch. 
Please also refer to comment 2 for my explanation. Thanks!
Comment 4 Philipp von Weitershausen [:philikon] 2012-08-03 16:00:41 PDT
Comment on attachment 648608 [details] [diff] [review]
Patch

Review of attachment 648608 [details] [diff] [review]:
-----------------------------------------------------------------

We can give this a shot. Worst thing that can happen is that the orange manifests as a timeout because we're stuck in a loop asking for "gsm list".
Comment 6 Ed Morley [:emorley] 2012-08-06 07:42:02 PDT
https://hg.mozilla.org/mozilla-central/rev/8e260b44e90d

Note You need to log in before you can comment on or make changes to this bug.