Allow initializing safe browsing's key manager without fetching a key

RESOLVED DUPLICATE of bug 783047

Status

()

Toolkit
Safe Browsing
RESOLVED DUPLICATE of bug 783047
5 years ago
4 years ago

People

(Reporter: Dolske, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Currently the Safe Browsing code has to jump through a few hoops to avoid setting the "keyUrl" used by the backend's key manager. It does this because apparently just the act of setting the URL results in a key being fetched from the URL, which would be unwanted if the user has disabled Safe Browsing.

This really ought to all be handled behind the scenes... We should be able to set the URL without triggering a fetch. Rather, the fetch should just be triggered on-demand if it's not available when an update is performed.
This will be fixed by the HTTPS switch, which does away with all the key-juggling.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 783047
(Assignee)

Updated

4 years ago
Component: Phishing Protection → Phishing Protection
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.