Closed Bug 779324 Opened 8 years ago Closed 5 years ago

Fullscreen requests from touch events are denied

Categories

(Core :: DOM: Core & HTML, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 966493

People

(Reporter: cpearce, Unassigned)

References

()

Details

(Keywords: regression, site-compat, Whiteboard: [lib-brightcove])

Fullscreen requests in user generated touch event handlers are being denied.

For example http://pearce.org.nz/fullscreen/touch.html

A user reported seeing an warning in the web console "Request for full-screen was denied because Element.mozRequestFullScreen() was not called from inside a short running user-generated event handler" (bug 687687 comment 13).

Perhaps nsEventStateManager::IsHandlingUserInput() is returning false for touch events?

WRT fullscreen, I'm not sure whether we want to grant requests in touch events or not; touches which don't have preventDefault() called on their touchstart or first touchmove still generate mouse events, and fullscreen requests are granted in user generated mouse click events. Denying fullscreen requests in touch events would prevent a page going fullscreen when the user panned/zoomed/scrolled, which may be desirable.
touchdown should be probably handled close to the way mousedown is.
ah, hmm, panning...that is a tricky case.
It can be difficult to get mouse click events out of touches when you already have a touchstart handler standing in the way (as when a framework intercepts touch events and converts them to simulated mouse events). The fullscreen API really needs to allow requests from touch event handlers.

Is anyone looking at this bug? Its birthday is coming up.
Any news on this? Chrome Mobile allows fullscreen from a touchstart handler.
This bug will prevent switching videos to full screen in Brightcove's new player (currently in beta, we are doing some preview testing). Brightcove is a very important video framework that powers many sites out there.

http://players.brightcove.com/2335723943001/ad40ec13-dcc3-47e8-8465-4d60b4917bac_default/
Whiteboard: [lib-brightcove]
I just noticed this bug affected my app http://mzl.la/BzDeck
Why regression keyword?
As per comments in Bug 687687, This is obviously a regression, right? Actually my app is using a custom event MenuItemSelected (to support both click and keydown), not a touch event, to invoke a fullscreen request.
See Also: → 1058700
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 966493
You need to log in before you can comment on or make changes to this bug.