libffi/configure should detect CC the same way as the top-level configure script

RESOLVED DUPLICATE of bug 748138

Status

RESOLVED DUPLICATE of bug 748138
6 years ago
8 months ago

People

(Reporter: philikon, Unassigned)

Tracking

Other Branch
x86_64
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Without setting CC/CXX in your mozconfig, libffi/configure defaults to gcc instead of clang on OSX. This would mix gcc and clang in the compilation phase (which is kind of bad) and could also result in a possible configure failure (depending on your CFLAGS).

Comment 1

6 years ago
I was standing over philikon's shoulder when we found this. An easy way to trigger this is to adjust your CFLAGS/CXXFLAGS to contain -fcolor-diagnostics or a similar flag not provided by /usr/bin/g++-4.2. configure in the top-level and js directories works fine. libffi fails out with a "C compiler cannot create executables" because libffi is set to error on warnings and the unknown -fcolor-diagnostics argument triggers a warning.
Blocks: 733905
Is this the same as 748138?

Comment 3

6 years ago
(In reply to Rafael Ávila de Espíndola (:espindola) from comment #2)
> Is this the same as 748138?

Sure looks like it.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 748138

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.