Turn off all tests on UX project branch

RESOLVED FIXED

Status

Release Engineering
General Automation
P2
normal
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: Callek, Assigned: coop)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [capacity][simple])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Per Bug 772458c#7 we should be good to turn off tests of all kinds on the UX branch. I'll leave it to others to determine if we need any further sign-off or whatever to make that happen though

Comment 1

6 years ago
Thank you for filing this :-)

Jared's comment for reference:

(In reply to Jared Wein [:jaws] from Bug 772458 comment #7)
> We can turn off tests for the UX branch (https://tbpl.mozilla.org/?tree=UX).
> I've been maintaining the branch for the past N months (doing daily merges
> between m-c and ux).
> 
> Devs sending their patch to UX branch can just run it through try server
> first and in total that will save some build resources since we have vastly
> more merges between m-c to ux then we do have checkins to ux.
> 
> It should also be noted that ux is a dead-end branch, which doesn't feed
> anywhere but is used for functional testing of new ux features.
OS: Windows 7 → All
Hardware: x86_64 → All
Whiteboard: [capacity][simple]
Would it be useful to still have Talos tests run?  People usually don't run them on try, and I feel like a few memory regressions from new features have shown up more clearly in the initial landing on UX.  But maybe not.

Updated

6 years ago
Assignee: nobody → coop
(Assignee)

Updated

6 years ago
Status: NEW → ASSIGNED
Priority: -- → P2
(Assignee)

Comment 3

6 years ago
Created attachment 648403 [details] [diff] [review]
Disable all tests on the ux project branch
Attachment #648403 - Flags: review?(armenzg)

Updated

6 years ago
Attachment #648403 - Flags: review?(armenzg) → review+
(Assignee)

Comment 4

6 years ago
Comment on attachment 648403 [details] [diff] [review]
Disable all tests on the ux project branch

https://hg.mozilla.org/build/buildbot-configs/rev/62aa36948414
Attachment #648403 - Flags: checked-in+
Just merged m-c to ux to test it out. Hopefully it wasn't too soon:
https://tbpl.mozilla.org/?tree=UX&rev=980d8540850e
The push to UX still ran the tests. Is there more work that needs to be done here?

Comment 7

6 years ago
buildbot-config landings require a reconfig before the changes take effect.
(Reporter)

Comment 8

6 years ago
This made it into production yesterday afternoon.
The latest merge shows no tests being run.

https://tbpl.mozilla.org/?tree=UX&rev=d1332a7f5913
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Duplicate of this bug: 785056

Updated

5 years ago
Depends on: 868092
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.