Last Comment Bug 779442 - Fix still more nsresult misuse
: Fix still more nsresult misuse
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All All
: -- minor (vote)
: mozilla17
Assigned To: Aryeh Gregor (:ayg) (next working March 28-April 26)
:
:
Mentors:
Depends on:
Blocks: nsresult-enum
  Show dependency treegraph
 
Reported: 2012-08-01 02:38 PDT by Aryeh Gregor (:ayg) (next working March 28-April 26)
Modified: 2012-08-08 09:27 PDT (History)
1 user (show)
ayg: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (4.50 KB, patch)
2012-08-01 02:42 PDT, Aryeh Gregor (:ayg) (next working March 28-April 26)
ehsan: review+
Details | Diff | Splinter Review

Description Aryeh Gregor (:ayg) (next working March 28-April 26) 2012-08-01 02:38:27 PDT

    
Comment 1 Aryeh Gregor (:ayg) (next working March 28-April 26) 2012-08-01 02:42:15 PDT
Created attachment 647892 [details] [diff] [review]
Patch

The imgStatusTracker field here is used as a PRUint32 by all callers that I see.  It's evidently meant to contain the values of an anonymous enum member of imgIRequest, so PRUint32 is the right type until someone gives it a name.

I'm not totally sure that the nsUrlClassifierStore change doesn't need module peer review -- it might be unintentional that it returns NS_OK.
Comment 2 Aryeh Gregor (:ayg) (next working March 28-April 26) 2012-08-01 02:43:04 PDT
Comment on attachment 647892 [details] [diff] [review]
Patch

(No part 2 intended here.)
Comment 3 Aryeh Gregor (:ayg) (next working March 28-April 26) 2012-08-08 02:27:51 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/e287b5a87971
Comment 4 Ed Morley [:emorley] 2012-08-08 09:27:28 PDT
https://hg.mozilla.org/mozilla-central/rev/e287b5a87971

Note You need to log in before you can comment on or make changes to this bug.