Last Comment Bug 779445 - SegFault in WorkerMemoryReporter because it accesses mWorkerPrivate when null (only in debug builds)
: SegFault in WorkerMemoryReporter because it accesses mWorkerPrivate when null...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: Tim Taubert [:ttaubert]
:
Mentors:
Depends on:
Blocks: 754671
  Show dependency treegraph
 
Reported: 2012-08-01 02:46 PDT by Tim Taubert [:ttaubert]
Modified: 2012-08-23 16:15 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
trivial patch (772 bytes, patch)
2012-08-01 02:46 PDT, Tim Taubert [:ttaubert]
bent.mozilla: review+
gavin.sharp: approval‑mozilla‑aurora+
Details | Diff | Review

Description Tim Taubert [:ttaubert] 2012-08-01 02:46:20 PDT
Created attachment 647893 [details] [diff] [review]
trivial patch

Working on bug 754671, my debug try builds crashed reliably in test_memoryReporters.xul. I could reproduce this locally and the culprit was pretty obvious. Attached a small patch that should fix this problem.
Comment 1 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-08-01 07:28:31 PDT
Comment on attachment 647893 [details] [diff] [review]
trivial patch

Review of attachment 647893 [details] [diff] [review]:
-----------------------------------------------------------------

Oops :-/

Thanks!
Comment 2 Tim Taubert [:ttaubert] 2012-08-01 10:27:28 PDT
https://hg.mozilla.org/integration/fx-team/rev/c7a4be29936e
Comment 3 Tim Taubert [:ttaubert] 2012-08-02 04:22:29 PDT
https://hg.mozilla.org/mozilla-central/rev/c7a4be29936e
Comment 4 Tim Taubert [:ttaubert] 2012-08-23 16:11:08 PDT
Comment on attachment 647893 [details] [diff] [review]
trivial patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): ?
User impact if declined: we need this for bug 754671.
Testing completed (on m-c, etc.): Landed a long time ago on nightly.
Risk to taking this patch (and alternatives if risky): Virtually no risk.
String or UUID changes made by this patch: None.
Comment 5 Tim Taubert [:ttaubert] 2012-08-23 16:15:09 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/d3d5c0b5aa75

Note You need to log in before you can comment on or make changes to this bug.