Closed Bug 779488 Opened 8 years ago Closed 8 years ago

Timeout error for testAddMozSearchProvider.js::testAddMozSearchPlugin

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: ioana_damy, Assigned: ioana_damy)

References

Details

Ioana! Thanks for your report! 

Mind checking if this error reproduces locally? 
I would be happy to guide you around in fixing this.
Assignee: nobody → ioana.budnar
Status: NEW → ASSIGNED
(In reply to Maniac Vlad Florin (:vladmaniac) from comment #1)
> Ioana! Thanks for your report! 
> 
> Mind checking if this error reproduces locally? 
> I would be happy to guide you around in fixing this.

Vlad, thanks for you offer. I'd be glad to try and fix this. 

I haven't tried to reproduce it locally yet because I don't have the required environment on Windows. I will update this bug as soon as I set the environment and get some results.
Duplicate of this bug: 779926
I ran this test locally a few times, both on Windows 7 and on Windows XP, and it never failed. I also checked on http://mozmill-ci.blargon7.com/ and there are no other fails for this test, except those in comment 0.

Anthony must've been right in bug 779926 comment 0 and this was just one-off connection glitch.

Please let me know if you need me to check anything else or simply close this bug.
I think we should close this as WORKSFORME, and reopen if it recurs. The search engine installed uses a page hosted on hg.mozilla.org, which may have been unavailable or responding slowly at the time. We could probably make this test use the local HTTP server, but I suspect this would involve dynamically creating the search engine XML file.
(In reply to Dave Hunt (:davehunt) from comment #5)
> I think we should close this as WORKSFORME, and reopen if it recurs. The
> search engine installed uses a page hosted on hg.mozilla.org, which may have
> been unavailable or responding slowly at the time. We could probably make
> this test use the local HTTP server, but I suspect this would involve
> dynamically creating the search engine XML file.

Agree - closing as WORKSFORME for now. If someone reproduces this locally, or see it in mozmill-ci report, please reopen. 
Then we can move on to implementing Dave's suggestions in comment 5
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Yeah, WORKSFORME is fine for me. I'll reopen if I notice this again with Firefox 15.0b4 testruns next week.
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.