Last Comment Bug 779641 - error occurred while processing 'attach' request: TypeError: this._tabActor._tabbrowser is undefined
: error occurred while processing 'attach' request: TypeError: this._tabActor._...
Status: RESOLVED FIXED
[fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: Trunk
: All All
: P2 normal (vote)
: Firefox 17
Assigned To: Panos Astithas [:past]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 14:18 PDT by Michael Schwartz [:m4]
Modified: 2012-08-03 14:27 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1.24 KB, patch)
2012-08-02 11:02 PDT, Panos Astithas [:past]
rcampbell: review+
Details | Diff | Splinter Review

Description Michael Schwartz [:m4] 2012-08-01 14:18:46 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.57 Safari/536.11

Steps to reproduce:

# Build b2g on tip from 7/31/12
# Setup for debugging as per this thread https://groups.google.com/forum/#!msg/mozilla.dev.b2g/UpDp2uTD4Mc/lM_Moiu2QRoJ
# Start b2g and verify debugging port listening
# Start up-to-date Firefox Nightly (8/1/12), enable remote debugging, enable debug logging, connect


Actual results:

Following error is printed from Firefox Nightly:

DBG-CLIENT: Got: {
  "from": "root",
  "applicationType": "browser",
  "traits": []
}
DBG-CLIENT: Got: {
  "from": "root",
  "selected": 0,
  "tabs": [
    { 
      "actor": "conn0.tab2",
      "url": "chrome://browser/content/shell.xul"
    }
  ]
}
DBG-CLIENT: Got: {
  "error": "unknownError",
  "message": "error occurred while processing 'attach' request: TypeError: this._tabActor._tabbrowser is undefined",
  "from": "conn0.tab2"
}



Expected results:

It should have connected with debugging
Comment 1 Michael Schwartz [:m4] 2012-08-01 14:24:23 PDT
Note, b2g refers to B2g desktop as per https://developer.mozilla.org/en/Mozilla/Boot_to_Gecko/Using_the_B2G_desktop_client
Everything run on Ubuntu 12.04 LTS x86
Comment 2 Panos Astithas [:past] 2012-08-02 07:09:58 PDT
Ugh, this is a regression from bug 751226, because it didn't take into account the changes in bug 751949 that I worked on at about the same time. I might had tested it before landing if I wasn't away on vacation, but we desperately need to run our tests against b2g. I'll have a patch ready, shortly.
Comment 3 Panos Astithas [:past] 2012-08-02 11:02:39 PDT
Created attachment 648392 [details] [diff] [review]
Patch v1

This was the simplest solution that worked and I think the best. Bug 751949 doesn't concern b2g or fennec, so it makes sense to keep them oblivious to the web progress listener's presence.
Comment 4 Panos Astithas [:past] 2012-08-02 11:14:07 PDT
Try run: https://tbpl.mozilla.org/?tree=Try&rev=868b15707fa7
Comment 5 Panos Astithas [:past] 2012-08-03 01:53:41 PDT
https://hg.mozilla.org/integration/fx-team/rev/2fdb5c89e9e2
Comment 6 Rob Campbell [:rc] (:robcee) 2012-08-03 14:27:39 PDT
https://hg.mozilla.org/mozilla-central/rev/2fdb5c89e9e2

Note You need to log in before you can comment on or make changes to this bug.