Last Comment Bug 77965 - News threads grouping very buggy (20010426)
: News threads grouping very buggy (20010426)
Status: VERIFIED DUPLICATE of bug 72493
:
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Message Display (show other bugs)
: Trunk
: x86 Windows 98
: -- major (vote)
: ---
Assigned To: (not reading, please use seth@sspitzer.org instead)
: stephend@netscape.com (gone - use stephen.donner@gmail.com instead)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-27 14:19 PDT by Skewer
Modified: 2004-11-22 17:25 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Skewer 2001-04-27 14:19:08 PDT
In build 20010426, the newsgroup listings behave very strangely when sorted into
groups. You can't sort them by subject, sender, or anything else, and only with
a strange workaround can messages be sorted by date, by clicking the group
button a second time (or a third to reverse the order). This doesn't even work
properly, some messages are still scattered around in the wrong place. For an
example, see the screenshot.
Comment 1 Skewer 2001-04-27 14:22:09 PDT
Grumble... Bugzilla's attachment system is still down. Here's the URL where you
can find the picture:

http://skewer.hypermart.net/mozmnbug.gif
Comment 2 Skewer 2001-04-27 14:24:17 PDT
I just noticed another bug in this screenshot: The newsgroup header seems to
print over the status bar...
Comment 3 (not reading, please use seth@sspitzer.org instead) 2001-04-27 14:47:38 PDT
adding david.
Comment 4 David :Bienvenu 2001-04-27 16:18:40 PDT
Do you mean you can't sort threads by date, subject, etc? that's an already
existing bug. bug 72493 - re the screenshot, I can't see anything useful there -
what am I missing?. If you click on another newsgroup and come back to this
group, is the thread still not right? If so, then it's just a problem putting
new headers into open newsgroups, and might have been fixed last night.
Comment 5 Skewer 2001-04-28 12:47:46 PDT
Pay attention to the red stuff, please... With regard to the parent messages,
messages from 4/19 should NOT appear between messages from 4/25! Instead, you
should be seeing messages from 4/25 on top (the way I have them sorted), then
4/24, 2/23... all the way down to 4/19. Also, the threading is all wrong in the
spot where I have the red arrow. How could you not notice this? This is a very
bad glitch!
Comment 6 Skewer 2001-04-28 12:55:45 PDT
Here's a shot of how Netscape 4 renders the thread:

http://skewer.hypermart.net/mozmncor.gif

Notice how the thread is branched out so that responses are listed below and to
the right of the message being responded to.
Comment 7 David :Bienvenu 2001-04-28 13:58:57 PDT
threads are sorted by arrival order of the first message that ever arrived in
the thread, not by date. (the first message in the thread may have expired so
that the first remaining messages may appear out of order) You want them to be
sorted by date; that's what the bug I pointed you at refers to. Re the red
arrow, that message looks like it's a reply and comes later than the message
that it was a reply to. Also, with newsgroups and nntp replication latency,
dates can be off, so again it was not obvious that the red arrow message was not
a reply to the earlier message.
Comment 8 Skewer 2001-04-28 17:32:58 PDT
What is important is that it does not sort the messages PROPERLY, as Netscape 4
does. I will get Monday's build and see if it works any better, but I think the
whole news code will have to be fixed up before this starts working the way it
should.

Half of this bug is now a duplicate of bug 72493, the grouping problem is now
the sole concern of this listing.

Also, I think the order in which messages are received from the server is
irrelevant, and should not be the default sorting order (I have never met anyone
that actually wanted their news messages sorted in this way).
Comment 9 Skewer 2001-04-28 17:34:10 PDT
...and I think it's bad that we used to have this feature, but it's now gone.
Somebody got fired for that, I hope...
Comment 10 TommyBee (No E-mail) 2001-05-01 20:41:01 PDT
I've always been under the impression that threads are supposed to be grouped in
a hierarchy such that replies to a certain message (which may or may not be a
reply to another message) appear directly under it, no matter when it was
received.  Something like this:

Root Message
- Reply 1
- - Reply 1 to Reply 1
- - Reply 2 to Reply 1
- - - Reply 1 to Reply 2 to Reply 1
- - Reply 3 to Reply 1
- Reply 2
- - Reply 1 to Reply 2
- - - Reply 1 to Reply 1 to Reply 2
- - - - Reply 1 to Reply 1 to Reply 1 to Reply 2
- Reply 3

You get the picture.  This is the way I prefer it -- the current sort by date is
rather annoying because a group of replies to a message may be interrupted by a
reply to a totally unconnected message in the thread.
Comment 11 David :Bienvenu 2001-05-02 16:23:15 PDT
Tommybee, you're correct; that's how it should work. I'll open a new bug for
that with a test case, and close this as a dup of bug 72943

*** This bug has been marked as a duplicate of 72943 ***
Comment 12 David :Bienvenu 2001-05-02 16:31:47 PDT
new bug is bug 78588. 
Comment 13 stephend@netscape.com (gone - use stephen.donner@gmail.com instead) 2001-05-03 01:06:34 PDT
verified duplicate.
Comment 14 Frank Belew 2001-05-03 09:31:27 PDT
Marked as Dupe of wrong bug
Comment 15 Frank Belew 2001-05-03 09:32:35 PDT
Marking as dupe of #72493

*** This bug has been marked as a duplicate of 72493 ***
Comment 16 David :Bienvenu 2001-05-03 09:41:27 PDT
thanks, you're right - darn dylsexia - verifying
Comment 17 stephend@netscape.com (gone - use stephen.donner@gmail.com instead) 2001-05-03 11:00:08 PDT
Sorry, I moused over the number that David mentioned the first time, read the
summary, and looked at the bug he marked it a DUP of, then verified.  I failed
to notice the # change, too ;-(.

Note You need to log in before you can comment on or make changes to this bug.