Last Comment Bug 779679 - FT2_ flags overriden by MOZ_TREE_FREETYPE env setup and fontconfig get's dropped
: FT2_ flags overriden by MOZ_TREE_FREETYPE env setup and fontconfig get's dropped
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Oleg Romashin (:romaxa)
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 16:29 PDT by Oleg Romashin (:romaxa)
Modified: 2012-08-05 09:27 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Append tree freetype flags libs to existing FT2_flags/libs (1.06 KB, patch)
2012-08-01 16:29 PDT, Oleg Romashin (:romaxa)
mh+mozilla: review-
Details | Diff | Splinter Review
Standalone fontconfig flags (3.63 KB, patch)
2012-08-03 16:48 PDT, Oleg Romashin (:romaxa)
mh+mozilla: review-
Details | Diff | Splinter Review
Standalone fontconfig flags (3.61 KB, patch)
2012-08-04 12:39 PDT, Oleg Romashin (:romaxa)
mh+mozilla: review+
Details | Diff | Splinter Review

Description Oleg Romashin (:romaxa) 2012-08-01 16:29:37 PDT
Created attachment 648137 [details] [diff] [review]
Append tree freetype flags libs to existing FT2_flags/libs

I'm trying to build simple linuxgl gecko build with FTConfig and getting FT2_FLAGS/LIBS overriden by 
http://mxr.mozilla.org/mozilla-central/source/configure.in#6047
Comment 1 Mike Hommey [:glandium] 2012-08-01 23:00:43 PDT
Comment on attachment 648137 [details] [diff] [review]
Append tree freetype flags libs to existing FT2_flags/libs

Review of attachment 648137 [details] [diff] [review]:
-----------------------------------------------------------------

::: configure.in
@@ +6111,2 @@
>     CAIRO_FT_CFLAGS='-I$(topsrcdir)/modules/freetype2/include'
> +   FT2_LIBS="'$(call EXPAND_LIBNAME_PATH,freetype,$(DEPTH)/modules/freetype2/.libs)' $FT2_LIBS"

That's not a good idea, because FT2_CFLAGS/LIBS contain flags for system freetype *and* fontconfig. What you really want is to add fontconfig flags alone.
Comment 2 Oleg Romashin (:romaxa) 2012-08-03 16:48:04 PDT
Created attachment 648898 [details] [diff] [review]
Standalone fontconfig flags

https://tbpl.mozilla.org/?tree=Try&rev=6517663604e5 - try build looks ok
Comment 3 Mike Hommey [:glandium] 2012-08-03 23:46:25 PDT
Comment on attachment 648898 [details] [diff] [review]
Standalone fontconfig flags

Review of attachment 648898 [details] [diff] [review]:
-----------------------------------------------------------------

::: configure.in
@@ +6047,5 @@
> +            FT2_CFLAGS="$FT2_CFLAGS $FONTCONFIG_CFLAGS"
> +            FT2_LIBS="$FT2_LIBS $FONTCONFIG_LIBS"
> +        fi
> +    ])
> +fi

There's another USE_FC_FREETYPE further down that's going to overwrite the FT2_* flags :(
Comment 4 Oleg Romashin (:romaxa) 2012-08-04 12:39:09 PDT
Created attachment 649026 [details] [diff] [review]
Standalone fontconfig flags

yep, I had that in mind but forgot to update a last moment. :(
Comment 5 Mike Hommey [:glandium] 2012-08-05 00:26:58 PDT
Comment on attachment 649026 [details] [diff] [review]
Standalone fontconfig flags

Review of attachment 649026 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good, assuming it passes linux try.
Comment 6 Oleg Romashin (:romaxa) 2012-08-05 09:14:56 PDT
https://tbpl.mozilla.org/?tree=Try&rev=a56a249624c8
Comment 7 Oleg Romashin (:romaxa) 2012-08-05 09:27:19 PDT
https://hg.mozilla.org/mozilla-central/rev/6c60e99d9739

Note You need to log in before you can comment on or make changes to this bug.