The default bug view has changed. See this FAQ.

Async pan/zoom broken

RESOLVED FIXED in mozilla17

Status

()

Core
Graphics: Layers
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: cjones, Assigned: cjones)

Tracking

unspecified
mozilla17
Points:
---

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

It don't work.

E/GeckoConsole( 1004): [JavaScript Error: "viewport is null" {file: "chrome://global/content/BrowserElementChild.js" line: 867}]

which is

  _recvViewportChange: function(data) {
    let viewport = data.json;

and the data originates from

TabChild::RecvUpdateFrame(const nsIntRect& aDisplayPort,
[snip]
{
    nsCString data;
    data += nsPrintfCString("{ \"x\" : %d", aScrollOffset.x);
    data += nsPrintfCString(", \"y\" : %d", aScrollOffset.y);
[snip]
    return RecvAsyncMessage(NS_LITERAL_STRING("Viewport:Change"),
                            NS_ConvertUTF8toUTF16(data));

(Yes, this is terrible.)

So it looks like the mm API changed, no longer |.json|, or our manually-built string isn't a valid structured clone.
Confirmed that https://hg.mozilla.org/integration/mozilla-inbound/rev/b83188166929 works.

Comment 2

5 years ago
I did mention at some point that I may or may not break that method - but since there
are no tests for it, had to guess.
Apparently I did break it. Someone who knows how to test the functionality needs to fix it 
(and add tests!).
Created attachment 648286 [details] [diff] [review]
Fix up shim code supporting hack to deliver mm message from C++
Assignee: nobody → jones.chris.g
Attachment #648286 - Flags: review?(bugs)

Comment 4

5 years ago
Comment on attachment 648286 [details] [diff] [review]
Fix up shim code supporting hack to deliver mm message from C++

Uh. sorry!
And thanks for fixing this.

Any chance to get some kind of test for this?
Attachment #648286 - Flags: review?(bugs) → review+
blocking-basecamp: --- → ?
This is a bustage fix, blocker.

https://hg.mozilla.org/integration/mozilla-inbound/rev/be31a4c795f7
blocking-basecamp: ? → +
(In reply to Olli Pettay [:smaug] from comment #4)
> Comment on attachment 648286 [details] [diff] [review]
> Fix up shim code supporting hack to deliver mm message from C++
> 
> Any chance to get some kind of test for this?

Yes.  The situation is complicated, sadly.
https://hg.mozilla.org/mozilla-central/rev/be31a4c795f7
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla17
You need to log in before you can comment on or make changes to this bug.