"Description already exists" error is displayed on the Additional Information field when submitting a new app

VERIFIED FIXED

Status

Marketplace
Developer Pages
P2
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: Cristian Boldan, Unassigned)

Tracking

({regression})

x86_64
Windows 7
regression
Points:
---
Dependency tree / graph

Details

(Reporter)

Description

5 years ago
Steps to reproduce:
1. Load My Submissions page and submit a new app ( https://marketplace-dev.allizom.org/en-US/developers/submit/app/ )
2. Enter a valid manifest and get to step 3 (Edit App Details page)
3. Complete all the required fields and click Continue.

Expected results:
There are no errors displayed, user is able to continue the submission process.

Actual results:
"Addon with this Description already exists." error is displayed on the Additional Information field, even if the field is not edited at all.

Notes/Issues:
Verified in FF17 (Win 7).Issue is not reproducing in production.
Screencast for this issue http://screencast.com/t/7ABilEHo6pYY
I don't get this on -dev.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

5 years ago
Issue is reproducing in https://addons-dev.allizom.org/en-US/developers/ on FF14 (Win 7)
Please see attached screencast http://screencast.com/t/lLNYcjjgt2AW
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 3

5 years ago
Cristian reopened this bug for AMO but I want to specify that I am able to reproduce it on MP too : http://screencast.com/t/zfRFiFWmndx

Please fix for both AMO and MP
Assignee: nobody → robhudson.mozbugs
Priority: -- → P2
Target Milestone: --- → 2012-08-16
Assignee: robhudson.mozbugs → mattbasta
Depends on: 784109
Target Milestone: 2012-08-16 → 2012-08-30

Comment 4

5 years ago
This was fixed when we turned on mixed mode replication.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

5 years ago
Verified as fixed in https://marketplace-dev.allizom.org/en-US/developers/submit/app/on FF18 and https://addons-dev.allizom.org/en-US/developers/addon/submit/1 on FF15 (Win 7)
Postfix screencast for MP http://screencast.com/t/rkyfPK0bjfMU and AMO http://screencast.com/t/3Tvl9suK
Closing bug.
Status: RESOLVED → VERIFIED

Comment 6

5 years ago
Reproduced again when tried to submit a packaged app on MP dev : http://screencast.com/t/fkIcAMzL
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
this is reproducible in our selenium tests too:

see  	tests.desktop.developer_hub.test_developer_hub.TestDeveloperHub.test_hosted_app_submission:


http://qa-selenium.mv.mozilla.com:8080/job/marketplace.dev.developer_hub/28/HTML_Report/?
http://qa-selenium.mv.mozilla.com:8080/job/marketplace.dev.developer_hub/29/HTML_Report/?
http://qa-selenium.mv.mozilla.com:8080/job/marketplace.dev.developer_hub/30/HTML_Report/?
Screen shoot:
http://i49.tinypic.com/14ne738.png

Comment 9

5 years ago
:cvan This seems similar to the AMO/Collections bug we were discussing and I'm not really comfortable with accepting it's a 'dev only' problem.

These issues are difficult for us QA team to debug in more detail because it looks like the validation is failing at db level and we don't have db access to query for duplicate records and report the IDs (or something like that).

This would help us provide more information but as it is we can only treat it a bit like a black box. We can only really report circumstances in which it worked or failed and even then these are a bit sporadic.

Is there anything we can do or information we can provide to help you debug these issues?

Comment 10

5 years ago
I'm convinced that this is some kind of race condition. I've manually connected to the database and stepped through query-by-query when this is happening "every time" and in that case, the bug doesn't present itself.

Perhaps we should loop Sheeri in on this to give some advice on how to debug this sort of thing more sanely. Maybe we can get access to the raw MySQL query logs to compare the order of the queries or maybe we're performing some kind of operation asynchronously that we should be performing synchronously.
I agree this is unacceptable. I've asked our team if we can do a DB refresh (last one was roughly over two months ago), which I'm hoping will fix this.

Comment 12

5 years ago
This issue is reproducible again in our Selenium tests on Jenkins.

Here is the stacktrace of the first time it failed:
http://qa-selenium.mv.mozilla.com:8080/job/marketplace.dev.developer_hub/130/testReport/junit/tests.desktop.developer_hub.test_developer_hub/TestDeveloperHub/test_hosted_app_submission/

Comment 13

5 years ago
That stacktrace doesn't mean much to a developer. Can you supply the screenshot at the point of the failure?

Include the application name or id that it was trying to create and also include the description that is supposedly the duplicate?

Then the developers have something to work with - they can search the database for the affected records.

Comment 14

5 years ago
More information for comment 12

Screenshot at the point of failure:
http://qa-selenium.mv.mozilla.com:8080/job/marketplace.dev.developer_hub/130/HTML_Report/debug/tests_desktop_developer_hub_test_developer_hub_TestDeveloperHub/test_hosted_app_submission/screenshot.png

Application name that was trying to be created: Mock Application 1351643063

In "Additional Information" field, the description that is supposedly the duplicate: more details of marble app 1351643063
Wil tells me that the update in 799168 means you don't need a DB refresh. Is that true?

I can get you query logs but I have to turn them on, and they get large quickly, so it would have to have an end time (e.g. logs for one day or one week or something like that).

Updated

5 years ago
Assignee: mattbasta → nobody
Basta, anything to do here? No?
Target Milestone: 2012-08-30 → ---
Guys what's the status of this bug? because it's no longer reproducible on marketplace developers pages
I will close it then.  From the above comments we were having difficulty reproducing it.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → FIXED
QA Verified!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.