Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 779740 - "Description already exists" error is displayed on the Additional Information field when submitting a new app
: "Description already exists" error is displayed on the Additional Information...
: regression
Product: Marketplace
Classification: Server Software
Component: Developer Pages (show other bugs)
: 1.0
: x86_64 Windows 7
: P2 normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
Depends on: 784109
Blocks: 766199
  Show dependency treegraph
Reported: 2012-08-02 01:28 PDT by Cristian Boldan
Modified: 2013-01-30 08:58 PST (History)
10 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Description Cristian Boldan 2012-08-02 01:28:15 PDT
Steps to reproduce:
1. Load My Submissions page and submit a new app ( )
2. Enter a valid manifest and get to step 3 (Edit App Details page)
3. Complete all the required fields and click Continue.

Expected results:
There are no errors displayed, user is able to continue the submission process.

Actual results:
"Addon with this Description already exists." error is displayed on the Additional Information field, even if the field is not edited at all.

Verified in FF17 (Win 7).Issue is not reproducing in production.
Screencast for this issue
Comment 1 Christopher Van Wiemeersch [:cvan] 2012-08-02 13:02:02 PDT
I don't get this on -dev.
Comment 2 Cristian Boldan 2012-08-09 08:34:45 PDT
Issue is reproducing in on FF14 (Win 7)
Please see attached screencast
Comment 3 Victor Carciu 2012-08-09 08:59:07 PDT
Cristian reopened this bug for AMO but I want to specify that I am able to reproduce it on MP too :

Please fix for both AMO and MP
Comment 4 Matt Basta [:basta] 2012-08-31 14:31:51 PDT
This was fixed when we turned on mixed mode replication.
Comment 5 Cristian Boldan 2012-09-03 08:25:21 PDT
Verified as fixed in FF18 and on FF15 (Win 7)
Postfix screencast for MP and AMO
Closing bug.
Comment 6 Victor Carciu 2012-10-03 02:01:19 PDT
Reproduced again when tried to submit a packaged app on MP dev :
Comment 7 Florin Strugariu [:Bebe] 2012-10-08 05:21:36 PDT
this is reproducible in our selenium tests too:

see  	tests.desktop.developer_hub.test_developer_hub.TestDeveloperHub.test_hosted_app_submission:
Comment 8 Florin Strugariu [:Bebe] 2012-10-08 05:26:45 PDT
Screen shoot:
Comment 9 Zac C (:zac) 2012-10-08 05:42:44 PDT
:cvan This seems similar to the AMO/Collections bug we were discussing and I'm not really comfortable with accepting it's a 'dev only' problem.

These issues are difficult for us QA team to debug in more detail because it looks like the validation is failing at db level and we don't have db access to query for duplicate records and report the IDs (or something like that).

This would help us provide more information but as it is we can only treat it a bit like a black box. We can only really report circumstances in which it worked or failed and even then these are a bit sporadic.

Is there anything we can do or information we can provide to help you debug these issues?
Comment 10 Matt Basta [:basta] 2012-10-08 08:45:54 PDT
I'm convinced that this is some kind of race condition. I've manually connected to the database and stepped through query-by-query when this is happening "every time" and in that case, the bug doesn't present itself.

Perhaps we should loop Sheeri in on this to give some advice on how to debug this sort of thing more sanely. Maybe we can get access to the raw MySQL query logs to compare the order of the queries or maybe we're performing some kind of operation asynchronously that we should be performing synchronously.
Comment 11 Christopher Van Wiemeersch [:cvan] 2012-10-08 09:14:33 PDT
I agree this is unacceptable. I've asked our team if we can do a DB refresh (last one was roughly over two months ago), which I'm hoping will fix this.
Comment 12 Teodosia Pop 2012-10-31 06:14:53 PDT
This issue is reproducible again in our Selenium tests on Jenkins.

Here is the stacktrace of the first time it failed:
Comment 13 Zac C (:zac) 2012-10-31 06:29:39 PDT
That stacktrace doesn't mean much to a developer. Can you supply the screenshot at the point of the failure?

Include the application name or id that it was trying to create and also include the description that is supposedly the duplicate?

Then the developers have something to work with - they can search the database for the affected records.
Comment 14 Teodosia Pop 2012-10-31 07:23:15 PDT
More information for comment 12

Screenshot at the point of failure:

Application name that was trying to be created: Mock Application 1351643063

In "Additional Information" field, the description that is supposedly the duplicate: more details of marble app 1351643063
Comment 15 Sheeri Cabral [:sheeri] 2012-10-31 08:21:55 PDT
Wil tells me that the update in 799168 means you don't need a DB refresh. Is that true?

I can get you query logs but I have to turn them on, and they get large quickly, so it would have to have an end time (e.g. logs for one day or one week or something like that).
Comment 16 Christopher Van Wiemeersch [:cvan] 2013-01-25 03:04:20 PST
Basta, anything to do here? No?
Comment 17 Trif Andrei-Alin[:AlinT] 2013-01-30 05:56:41 PST
Guys what's the status of this bug? because it's no longer reproducible on marketplace developers pages
Comment 18 Wil Clouser [:clouserw] 2013-01-30 08:42:59 PST
I will close it then.  From the above comments we were having difficulty reproducing it.
Comment 19 Trif Andrei-Alin[:AlinT] 2013-01-30 08:58:09 PST
QA Verified!

Note You need to log in before you can comment on or make changes to this bug.