Last Comment Bug 779811 - When zoomed Text-selection handles separate from selection on device rotation
: When zoomed Text-selection handles separate from selection on device rotation
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: Text Selection (show other bugs)
: 15 Branch
: ARM Android
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 764467
Blocks: text-selection 766556
  Show dependency treegraph
 
Reported: 2012-08-02 04:58 PDT by Adrian Tamas (:AdrianT)
Modified: 2016-07-29 14:29 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
verified
unaffected
unaffected
15+


Attachments

Description Adrian Tamas (:AdrianT) 2012-08-02 04:58:40 PDT
Follow-up to: Bug 766556 which was closed as fixed but the fix was never uplifted to Beta

Firefox Mobile Native Beta 15.0b3
Device: Motorola Droid Pro (Android 2.3.4)/ Samsung Galaxy R(Android 2.3.4)

Steps to reproduce:
1. Go to cnn.com
2. Select a word
3. Rotate the device in landscape mode

Expected results:
Selection handles are correctly displayed

Actual results:
The handles are detached from the selected text
Comment 1 Aaron Train [:aaronmt] 2012-08-02 06:56:06 PDT

*** This bug has been marked as a duplicate of bug 766556 ***
Comment 2 Kevin Brosnan [:kbrosnan] 2012-08-02 11:32:21 PDT
I can reproduce this on Beta.

1. Go to cnn.com
2. zoom into some text
3. Select a word
4. Rotate the device in landscape mode

Aurora and Nightly have a different behavior where the handles are removed
Comment 3 :Margaret Leibovic 2012-08-02 13:34:11 PDT
We discussed this on IRC, but for the record, it looks like we just need to uplift bug 764467 to fix this problem.
Comment 4 Kartikaya Gupta (email:kats@mozilla.com) 2012-08-07 07:13:29 PDT
Sorry for the delay, bug 764467 has been uplifted to beta now so this should be fixed in the next beta.
Comment 5 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-09 10:24:57 PDT
Un-tracking and marking this fixes as per landing in bug 764467
Comment 6 Kevin Brosnan [:kbrosnan] 2012-08-09 10:25:40 PDT
Fixed in Fennec 15b4.
Comment 7 Cristian Nicolae (:xti) 2012-09-06 07:00:20 PDT
Indeed, the bug is fixed on the latest Firefox 15 build. Closing bug as verified fixed on:

Firefox 15.0.1 (2012-09-05)
Device: Galaxy Note
OS: Android 4.0.4

Note You need to log in before you can comment on or make changes to this bug.