Last Comment Bug 779818 - IonMonkey: Assertion failure: false (unexpected constant type), at ion/shared/Lowering-shared.cpp:33
: IonMonkey: Assertion failure: false (unexpected constant type), at ion/shared...
Status: RESOLVED FIXED
[jsbugmon:update][ion:p1:fx18]
: assertion, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Other Branch
: x86_64 Linux
: -- major (vote)
: ---
Assigned To: Nicolas B. Pierron [:nbp]
: general
Mentors:
: 779691 (view as bug list)
Depends on:
Blocks: langfuzz IonFuzz
  Show dependency treegraph
 
Reported: 2012-08-02 05:29 PDT by Christian Holler (:decoder)
Modified: 2013-02-07 05:17 PST (History)
8 users (show)
choller: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Substitute MPhi of Magic type by the lazy argument constant. (2.11 KB, patch)
2012-08-02 22:20 PDT, Nicolas B. Pierron [:nbp]
dvander: review+
nicolas.b.pierron: checkin+
Details | Diff | Review

Description Christian Holler (:decoder) 2012-08-02 05:29:53 PDT
The following testcase asserts on ionmonkey revision 2169bca0c9a5 (run with --ion -n -m --ion-eager -a):


var SECTION = "lexical-015";
(function() {
    for (var a = 0; a < 9; a++) {
        if (SECTION[a]) {
            while (arguments[a]) break;
        }
    }
})()
Comment 1 Christian Holler (:decoder) 2012-08-02 05:31:28 PDT
Please also run this test in an optimized build. You'll notice that it just aborts (you'll get "Aborted" but nothing else). I don't think this is the right behavior, even if opt builds are supposed to be stopped at that point.
Comment 2 Nicolas B. Pierron [:nbp] 2012-08-02 10:39:19 PDT
This is likely the MPhi issue with OSR block found by Marty yesterday.
Comment 3 Nicolas B. Pierron [:nbp] 2012-08-02 11:29:08 PDT
*** Bug 779691 has been marked as a duplicate of this bug. ***
Comment 4 Nicolas B. Pierron [:nbp] 2012-08-02 22:20:12 PDT
Created attachment 648616 [details] [diff] [review]
Substitute MPhi of Magic type by the lazy argument constant.
Comment 5 Nicolas B. Pierron [:nbp] 2012-08-06 17:37:09 PDT
Comment on attachment 648616 [details] [diff] [review]
Substitute MPhi of Magic type by the lazy argument constant.

https://hg.mozilla.org/projects/ionmonkey/rev/15db586f9a12
Comment 6 Christian Holler (:decoder) 2012-08-06 18:21:51 PDT
JSBugMon: The testcase found in this bug no longer reproduces (tried revision 15db586f9a12).
Comment 7 Christian Holler (:decoder) 2013-02-07 05:17:27 PST
Automatically extracted testcase for this bug was committed:

https://hg.mozilla.org/mozilla-central/rev/2e891e0db397

Note You need to log in before you can comment on or make changes to this bug.