The default bug view has changed. See this FAQ.

java.lang.IllegalArgumentException: Invalid size <n> at org.mozilla.gecko.mozglue.DirectBufferAllocator.allocate(DirectBufferAllocator.java)

RESOLVED FIXED in Firefox 17

Status

()

Firefox for Android
General
--
critical
RESOLVED FIXED
5 years ago
8 months ago

People

(Reporter: Scoobidiver (away), Assigned: vlad)

Tracking

({crash, regression, topcrash})

17 Branch
Firefox 17
ARM
Android
crash, regression, topcrash
Points:
---

Firefox Tracking Flags

(firefox16 unaffected, firefox17 fixed)

Details

(Whiteboard: [native-crash][startupcrash], crash signature)

(Reporter)

Description

5 years ago
There are currently 9 crashes from 2 users in 17.0a1/20120802, including bp-2f979e33-1a97-4a93-a067-928a72120802.
The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=582d4c67b3a7&tochange=588424024294
It's likely a regression from bug 779366

java.lang.IllegalArgumentException: Invalid size 37286
	at org.mozilla.gecko.mozglue.DirectBufferAllocator.allocate(DirectBufferAllocator.java:21)
	at org.mozilla.gecko.Tab.getThumbnailBuffer(Tab.java:147)
	at org.mozilla.gecko.GeckoApp.getAndProcessThumbnailForTab(GeckoApp.java:637)
	at org.mozilla.gecko.GeckoApp$21.run(GeckoApp.java:1301)
	at android.os.Handler.handleCallback(Handler.java:615)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at org.mozilla.gecko.GeckoBackgroundThread.run(GeckoBackgroundThread.java:31)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.IllegalArgumentException%3A+Invalid+size+37286+at+org.mozilla.gecko.mozglue.DirectBufferAllocator.allocate%28DirectBufferAllocator.java%29
(Assignee)

Comment 1

5 years ago
After irc discussion, just landed direct on m-c: http://hg.mozilla.org/mozilla-central/rev/e62747d22841 .  Will trigger nightly respin shortly.
Assignee: nobody → vladimir
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
Target Milestone: --- → Firefox 17
(In reply to Vladimir Vukicevic [:vlad] [:vladv] from comment #1)
> After irc discussion, just landed direct on m-c:
> http://hg.mozilla.org/mozilla-central/rev/e62747d22841 .  Will trigger
> nightly respin shortly.

Thanks, Vlad!
status-firefox16: --- → unaffected
status-firefox17: --- → fixed
(Reporter)

Comment 3

5 years ago
(In reply to Vladimir Vukicevic [:vlad] [:vladv] from comment #1)
> Will trigger nightly respin shortly.
Not done.
Crash Signature: [@ java.lang.IllegalArgumentException: Invalid size 37286 at org.mozilla.gecko.mozglue.DirectBufferAllocator.allocate(DirectBufferAllocator.java)] → [@ java.lang.IllegalArgumentException: Invalid size 37286 at org.mozilla.gecko.mozglue.DirectBufferAllocator.allocate(DirectBufferAllocator.java)] [@ java.lang.IllegalArgumentException: Invalid size 13054 at org.mozilla.gecko.mozglue.DirectBufferA&hellip;
Keywords: topcrash
Summary: java.lang.IllegalArgumentException: Invalid size 37286 at org.mozilla.gecko.mozglue.DirectBufferAllocator.allocate(DirectBufferAllocator.java) → java.lang.IllegalArgumentException: Invalid size <n> at org.mozilla.gecko.mozglue.DirectBufferAllocator.allocate(DirectBufferAllocator.java)
(Reporter)

Updated

5 years ago
Duplicate of this bug: 779963
Seems to be a 17 only crash; 16 not affected.  Crashes only seen on the 8/2 from 3 day report.

https://crash-stats.mozilla.com/query/query?product=FennecAndroid&version=ALL%3AALL&range_value=1&range_unit=weeks&date=08%2F06%2F2012+17%3A07%3A29&query_search=signature&query_type=contains&query=+%09java.lang.IllegalArgumentException%3A+Invalid+size&reason=&build_id=&process_type=any&hang_type=any&do_query=1
You need to log in before you can comment on or make changes to this bug.