Last Comment Bug 779873 - <Anoymous> instead of <Anonymous>
: <Anoymous> instead of <Anonymous>
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Gecko Profiler (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-02 09:11 PDT by Andrew McCreight [:mccr8]
Modified: 2012-08-06 23:45 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Andrew McCreight [:mccr8] 2012-08-02 09:11:43 PDT
This is kind of silly, and I'm not sure what is to blame, but in the profiler, it seems to be showing anonymous functions as "<Anoymous>" instead of "<Anonymous>".  One example is http://people.mozilla.com/~bgirard/cleopatra/?report=f89b6f9590df7ed2ff96336e4ec2d67c9b6d5f1c
Comment 1 Jim Blandy :jimb 2012-08-02 14:09:51 PDT
Seems like that's a common typo. Looks like there's some unused code:

./services/sync/tps/extensions/mozmill/resource/modules/elementslib.js:271:  var nodes = [e for each (e in _document.getAnoymousNodes(element)) if (e)];

Note You need to log in before you can comment on or make changes to this bug.