Last Comment Bug 780111 - Share code with new DOM bindings for primitive conversions in XPCConvert::JSData2Native
: Share code with new DOM bindings for primitive conversions in XPCConvert::JSD...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: :Ms2ger
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 04:23 PDT by :Ms2ger
Modified: 2012-08-04 18:41 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (4.26 KB, patch)
2012-08-03 04:23 PDT, :Ms2ger
bobbyholley: review+
Details | Diff | Review

Description :Ms2ger 2012-08-03 04:23:01 PDT
Created attachment 648663 [details] [diff] [review]
Patch v1

If only because you can bet that bz will make that code as fast as possible.
Comment 1 Bobby Holley (PTO through June 13) 2012-08-03 04:55:22 PDT
Comment on attachment 648663 [details] [diff] [review]
Patch v1

Hell yeah. I haven't looked much at the implementations in PrimitiveConversions.h, but assuming they work this looks great!
Comment 3 Ed Morley [:emorley] 2012-08-04 11:30:07 PDT
Backed out with the mass tree revert to get rid of the OS X M5 orange:
https://hg.mozilla.org/mozilla-central/rev/c801b99d726f
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-08-04 13:34:55 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/a184e7de6ba9
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-08-04 18:41:51 PDT
https://hg.mozilla.org/mozilla-central/rev/a184e7de6ba9

Note You need to log in before you can comment on or make changes to this bug.