Last Comment Bug 780145 - ArchiveReader doesn't unzip large files
: ArchiveReader doesn't unzip large files
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla17
Assigned To: Andrea Marchesini [:baku]
:
: Andrew Overholt [:overholt]
Mentors:
: 781155 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 07:12 PDT by Andrea Marchesini [:baku]
Modified: 2012-08-08 18:24 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Bug 780145 - ArchiveReader doesn't unzip large files (1.58 KB, patch)
2012-08-03 09:23 PDT, Andrea Marchesini [:baku]
jst: review+
Details | Diff | Splinter Review
Bug 780145 - ArchiveReader doesn't unzip large files, r=jst (5.89 KB, patch)
2012-08-07 09:33 PDT, Andrea Marchesini [:baku]
jst: review+
jst: checkin+
Details | Diff | Splinter Review

Description Andrea Marchesini [:baku] 2012-08-03 07:12:09 PDT
ArchiveReader doesn't unzip large files
Comment 1 Andrea Marchesini [:baku] 2012-08-03 09:23:18 PDT
Created attachment 648741 [details] [diff] [review]
Bug 780145 - ArchiveReader doesn't unzip large files

wrong usage of the avail_out value.
Comment 2 Andrea Marchesini [:baku] 2012-08-07 08:19:51 PDT
Comment on attachment 648741 [details] [diff] [review]
Bug 780145 - ArchiveReader doesn't unzip large files

I have to optimize a corner-case. So please don't check-in this patch yet.
Comment 3 Andrea Marchesini [:baku] 2012-08-07 09:33:16 PDT
Created attachment 649674 [details] [diff] [review]
Bug 780145 - ArchiveReader doesn't unzip large files, r=jst
Comment 4 Andrea Marchesini [:baku] 2012-08-07 10:50:35 PDT
Comment on attachment 649674 [details] [diff] [review]
Bug 780145 - ArchiveReader doesn't unzip large files, r=jst

Green on try.
Comment 5 Andrea Marchesini [:baku] 2012-08-08 06:27:07 PDT
*** Bug 781155 has been marked as a duplicate of this bug. ***
Comment 6 Johnny Stenback (:jst, jst@mozilla.com) 2012-08-08 11:11:52 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/7e0466ba65c4
Comment 7 Ryan VanderMeulen [:RyanVM] 2012-08-08 18:24:33 PDT
https://hg.mozilla.org/mozilla-central/rev/7e0466ba65c4

Note You need to log in before you can comment on or make changes to this bug.