Last Comment Bug 780160 - Help with copy for the Socorro Email project
: Help with copy for the Socorro Email project
Status: RESOLVED FIXED
:
Product: Marketing
Classification: Other
Component: Copy (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Matej Novak [:matej]
:
:
Mentors:
Depends on:
Blocks: 814647
  Show dependency treegraph
 
Reported: 2012-08-03 08:08 PDT by Verdi [:verdi]
Modified: 2013-07-02 15:28 PDT (History)
6 users (show)
See Also:
Due Date:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Verdi [:verdi] 2012-08-03 08:08:21 PDT
We're working on a project to automatically send out an HTML email to everyone who submits their email address after a Firefox crash. To begin with we'll just send one general note to everyone. 

The project etherpad is here: https://etherpad.mozilla.org/socorro-email-Q3-2012

I put together this initial draft from emails that we've sent out in the past:

Subject: Thanks for sending us info about your Firefox crash

Dear Firefox user,
Some time ago Firefox crashed and we're really sorry about that. We'll use the crash report and comments that you sent to try to make sure that doesn't happen again. Until then, here are a couple of things you can do prevent crashes from happening:

1. If you are not already using the latest version of Firefox, please download and install it from mozilla.org. [Link: http://mozilla.org/firefox] 

2. Check out this article [Link: http://mzl.la/Kpf7Zn] which explains how to troubleshoot the cause of a crash and how to get help fixing it.

Thanks,
Mozilla Firefox

P.S. This message was sent out by one of our friendly Mozilla email bots. Please don't try to reply, they're terrible at receiving email. Instead, you can give feedback directly to our Firefox developers (real people) here - http://input.mozilla.org

--
You will not receive any more email about this particular crash. To unsubscribe from messages about other crash reports that you've submitted, please follow this link: *|UNSUBSCRIBE_URL|*
Comment 1 Matej Novak [:matej] 2012-08-03 09:06:50 PDT
I think this email looks great! I just made a few really small changes, mostly stylistic. Let me know if you have any questions.


Subject: Thanks for sending us info about your Firefox crash

Dear Firefox user,

Some time ago, your Firefox crashed and we're really sorry about that. We'll use the crash report and comments that you sent to try to make sure it doesn't happen again. Until then, here are a couple of things you can do prevent further crashes:

1. If you're not already using the latest version of Firefox, please download and install it now from mozilla.org. [Link: http://mozilla.org/firefox] 

2. Check out this article, [Link: http://mzl.la/Kpf7Zn] which explains how to troubleshoot the cause of a crash and how to get help fixing it.

Thanks,
Mozilla Firefox

P.S. This message was sent by one of our friendly Mozilla email bots. Please don't try to reply — they're terrible at receiving email. Instead, you can give feedback directly to our Firefox developers (real people) here: http://input.mozilla.org

--
You will not receive any more email about this particular crash. To unsubscribe from messages about other crash reports that you've submitted, please follow this link: *|UNSUBSCRIBE_URL|*
Comment 2 Verdi [:verdi] 2012-08-08 12:03:09 PDT
Thanks Matej! This looks good to me.

Cheng, Laura and Laura - what do you think? Does the content here satisfy what we want to accomplish with the initial version?
Comment 3 Adrian Gaudebert [:adrian] 2013-01-03 03:24:25 PST
The code to send those emails is almost ready (currently waiting for review, see bug 814647 ), but we do not have a real email in ExactTarget. Can anyone please create the email that you folks want to send, and give me the id of that email?
Comment 4 Verdi [:verdi] 2013-01-07 13:19:37 PST
Hey Cheng, what's the next step here? This bug seems done to me. Who would create the actual email?
Comment 5 [:Cww] 2013-01-07 13:32:32 PST
I'm getting an Exact target account to write the email and then we'll forge ahead.
Comment 6 Adrian Gaudebert [:adrian] 2013-01-16 05:09:31 PST
Cheng, did you get to create the template? If so can you please give me the ID of that template, so we can start testing the system on our dev/stage environments?
Comment 7 John Hesling [:John99] (NeedInfo me) 2013-06-04 19:45:37 PDT
We are already sending emails,and may have revised them, but they are still broken. They do not link correctly to the Crash Report, that is a major flaw. See https://support.mozilla.org/en-US/forums/contributors/709164
Comment 8 [:Cww] 2013-06-04 23:05:09 PDT
Indeed, I think we were having problems getting that customization through our email system so we have to send the same email for each user.
Comment 9 John Hesling [:John99] (NeedInfo me) 2013-06-05 07:57:07 PDT
Thanks for the reply Cheng. If that is the case we certainly have no need to send the email too often, but can we improve it so that from the standard email alone the user realises a personalised crash report is easily available.  

Possibly consider adding something along the lines of

>3. To look at your very own detailed and specific crash report 
>follow the *instructions* to obtain a Crash ID (starting bp-) 
>and paste that into the crash *search box*
>(* repeat the links to the kb article and the crash-stats)  

As it stands I suspect a link to the crash stats front page is not much use to the average user. Using *crash report* as an anchor for that link is misleading.

Current email
>.... We'll use the *crash report* and comments that you send to try
> to make sure it does'nt happen again ....

Note You need to log in before you can comment on or make changes to this bug.