Last Comment Bug 780203 - add some stdint types to xpidl
: add some stdint types to xpidl
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla17
Assigned To: Trevor Saunders (:tbsaunde)
:
: Nathan Froyd [:froydnj]
Mentors:
Depends on:
Blocks: 783609 783615
  Show dependency treegraph
 
Reported: 2012-08-03 10:16 PDT by Trevor Saunders (:tbsaunde)
Modified: 2012-08-17 11:03 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.39 KB, patch)
2012-08-03 10:20 PDT, Trevor Saunders (:tbsaunde)
no flags Details | Diff | Splinter Review
patch v2 (2.37 KB, patch)
2012-08-03 11:30 PDT, Trevor Saunders (:tbsaunde)
khuey: review+
Details | Diff | Splinter Review

Description Trevor Saunders (:tbsaunde) 2012-08-03 10:16:48 PDT

    
Comment 1 Trevor Saunders (:tbsaunde) 2012-08-03 10:20:58 PDT
Created attachment 648761 [details] [diff] [review]
patch

This adds [u]intn_t types to xpidl that map to the c++ type by the same name, which should help us move towards more stdint types (hopefully)

I didn't add a int8_t type because xpidl doesn't have a signed 8 bit type, and I sort of figure if we haven't needed it yet its not worth bothering with, but if you like I could try.
Comment 2 Ted Mielczarek [:ted.mielczarek] 2012-08-03 10:46:40 PDT
Comment on attachment 648761 [details] [diff] [review]
patch

Review of attachment 648761 [details] [diff] [review]:
-----------------------------------------------------------------

::: xpcom/idl-parser/typelib.py
@@ +23,5 @@
> +    'int64_t':          xpt.Type.Tags.int64,
> +    'uint8_t':              xpt.Type.Tags.uint8,
> +    'uint16_t':     xpt.Type.Tags.uint16,
> +    'uint32_t':      xpt.Type.Tags.uint32,
> +    'uint64_t': xpt.Type.Tags.uint64,

What's up with the goofy formatting here?
Comment 3 Trevor Saunders (:tbsaunde) 2012-08-03 11:16:14 PDT
(In reply to Ted Mielczarek [:ted] from comment #2)
> Comment on attachment 648761 [details] [diff] [review]
> patch
> 
> Review of attachment 648761 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: xpcom/idl-parser/typelib.py
> @@ +23,5 @@
> > +    'int64_t':          xpt.Type.Tags.int64,
> > +    'uint8_t':              xpt.Type.Tags.uint8,
> > +    'uint16_t':     xpt.Type.Tags.uint16,
> > +    'uint32_t':      xpt.Type.Tags.uint32,
> > +    'uint64_t': xpt.Type.Tags.uint64,
> 
> What's up with the goofy formatting here?

I have no idea, my best guess is that I screwed it up somehow and didn't notice because of screen reader not being setup to read whitespace by default, and of course that I forgot to check manually :(
Comment 4 Trevor Saunders (:tbsaunde) 2012-08-03 11:30:13 PDT
Created attachment 648782 [details] [diff] [review]
patch v2

make whitespace nicer.
Comment 5 Trevor Saunders (:tbsaunde) 2012-08-07 18:33:12 PDT
landed https://hg.mozilla.org/integration/mozilla-inbound/rev/4bdc7b03597e
Comment 6 Ed Morley [:emorley] 2012-08-08 09:30:10 PDT
https://hg.mozilla.org/mozilla-central/rev/4bdc7b03597e
Comment 7 :Ms2ger (⌚ UTC+1/+2) 2012-08-09 04:46:19 PDT
Somehow the goofy formatting got landed :(
Comment 8 Trevor Saunders (:tbsaunde) 2012-08-09 04:58:16 PDT
ugh
https://hg.mozilla.org/integration/mozilla-inbound/rev/e3422c4a00b4
Comment 9 :Ehsan Akhgari 2012-08-09 10:34:52 PDT
Ah, can we back this out please?  This will break what I have in bug 579517.  This will be fixed when those patches land.
Comment 10 :Ehsan Akhgari 2012-08-09 11:22:40 PDT
Sigh.  I think I'll have to rebase my work on top of this.  :(
Comment 11 Ryan VanderMeulen [:RyanVM] 2012-08-09 15:01:40 PDT
https://hg.mozilla.org/mozilla-central/rev/e3422c4a00b4
Comment 12 Trevor Saunders (:tbsaunde) 2012-08-09 21:01:43 PDT
(In reply to Ehsan Akhgari [:ehsan] from comment #9)
> Ah, can we back this out please?  This will break what I have in bug 579517.
> This will be fixed when those patches land.

if you haven't already rebased on top of it I guess so.
Comment 13 Trevor Saunders (:tbsaunde) 2012-08-09 21:02:12 PDT
(In reply to Ehsan Akhgari [:ehsan] from comment #10)
> Sigh.  I think I'll have to rebase my work on top of this.  :(

sorry, I didn't respond earlier I was out all afternoon.
Comment 14 :Ehsan Akhgari 2012-08-10 10:59:47 PDT
No problem, turns out that this doesn't hurt my work :-)

Note You need to log in before you can comment on or make changes to this bug.