If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[l10n] "Full screen" mode hides tool bar entirely when translating an article

RESOLVED WORKSFORME

Status

Mozilla Developer Network
Editing
P2
normal
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: openjck, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120726160848

Steps to reproduce:

1. Load this page: https://developer-new.mozilla.org/en-US/docs/HTML/HTML5$translate?tolocale=fy-NL
2. Scroll down until the top of the WYSIWYG has a tapered white border.
3. Press the fullscreen button. Notice problem.
4. Scroll up until the tapered border disappears. Notice problem is gone.


Actual results:

Page looks weird (https://bug766658.bugzilla.mozilla.org/attachment.cgi?id=637259). If you scroll up until the tapered border disappears and then hit the "fullscreen" button again, it works fine.


Expected results:

Normal fullscreen (the second half of "What happened" above).
(Reporter)

Updated

5 years ago
Priority: -- → P3
(Assignee)

Updated

5 years ago
Version: Kuma → unspecified
(Assignee)

Updated

5 years ago
Component: Website → Landing pages
Product: Mozilla Developer Network → Mozilla Developer Network
Morphing this bug a bit. I can not reproduce what John described a year ago with the new design now. These issues seem to be gone.

However, if you go to full screen mode when editing a translation, the wysiwyg tool bar is gone at all. So you can't save or get back to the normal view. Also hitting the Esc key as a shortcut to quit full screen mode would be nice to have in both, translation edit and normal page edit.
Component: Landing pages → Editing
Priority: P3 → P2
Summary: "Full screen" WYSIWYG button doesn't work in some cases → [l10n] "Full screen" mode hides tool bar entirely when translating an article
I'm seeing this:  http://screencast.com/t/HGslkXyGQFx
My screencast in Firefox Nightly, Ubuntu, MDN production site: http://www.screencast.com/t/HCCYyPbRmA
(Reporter)

Comment 4

4 years ago
I can't reproduce comment 1 or comment 0 any more.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.