Last Comment Bug 780332 - rm getTypedArray
: rm getTypedArray
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla17
Assigned To: general
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 18:37 PDT by Luke Wagner [:luke]
Modified: 2012-08-13 10:48 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
rm (15.04 KB, patch)
2012-08-03 18:37 PDT, Luke Wagner [:luke]
wmccloskey: review+
Details | Diff | Splinter Review

Description Luke Wagner [:luke] 2012-08-03 18:37:43 PDT
Created attachment 648926 [details] [diff] [review]
rm

IIUC, the result of all this wrapper-purity work in typed arrays is that we don't need this goofy proto-chain walk in getTypedArray:
 - for the js::Class hooks (like obj_getProperty), 'obj' is the typed array (even with wrapped objects, do you know of any exceptions bholley?)
 - for the natives, CallNonGenericMethod does the right thing
 - JSPropertyOp was the remaining case where the given obj is the 'receiver', not the object holding the property, but sfink magnanimously converted them to be accessor properties so the generic accessor mechanism sorts it out

Any other corner cases I'm missing?  Passes jit tests which I believe hold tests for all the issues we've seen in the last few months.  Try'ing now.
Comment 1 [PTO to Dec5] Bill McCloskey (:billm) 2012-08-03 18:43:30 PDT
Comment on attachment 648926 [details] [diff] [review]
rm

Thanks!
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-08-06 17:11:28 PDT
https://hg.mozilla.org/mozilla-central/rev/1e9ec6f54266
Comment 4 Steve Fink [:sfink] [:s:] 2012-08-13 10:48:08 PDT
Thanks! I meant to file a followup bug to do exactly this, but never got around to it. Probably because I didn't understand the dependency chain, which is a bad excuse.

Note You need to log in before you can comment on or make changes to this bug.