Closed Bug 780363 Opened 7 years ago Closed 5 years ago

Pages which have special characters in slug are missing

Categories

(developer.mozilla.org :: Editing, defect, P2, critical)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: potappo, Assigned: jezdez)

References

Details

(Whiteboard: [type:bug])

Les, Luke: Thoughts?

Sheppy: Thoughts? Priority?
This is a fairly big deal; some of those pages are important (especially the C++ Portability Guide and DebugOnly<T>, for example.
Severity: major → critical
Priority: -- → P1
So the good news is the pages are there and it's probably just an issue with the url resolver and/or slug matcher having trouble with the characters. Still digging ...
Whiteboard: s=2012-08-22
See also bug 781066, sounds like the same issue or a dupe
Whiteboard: s=2012-08-22 → s=2012-08-22 p=2
Blocks: 781066
Blocks: 781328
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → jbennett
Whiteboard: s=2012-08-22 p=2 → s=2012-08-22 p=2 s=2012-08-29
Whiteboard: s=2012-08-22 p=2 s=2012-08-29 → s=2012-08-22 p=2 s=2012-09-05
James: Are you still working on this. Luke could take it on if you're not.
Depends on: 788830
Duplicate of this bug: 781066
Version: Kuma → unspecified
Component: Website → Landing pages
Handing this one back because I'm stumped. It doesn't appear to be a mod_rewrite issue, per my comment in bug 781066, but I can't for the life of me figure out how/why Django is screwing this up.

I suspect this is going to be something really simple that I'm just overlooking, though.
Assignee: jbennett → nobody
Component: Landing pages → Editing
Whiteboard: s=2012-08-22 p=2 s=2012-09-05 → s=2012-08-22 p=2 s=2012-09-05 c=Editing
Working around a bug in Scrumbugs.
Whiteboard: s=2012-08-22 p=2 s=2012-09-05 c=Editing → p=2 c=Editing
Whiteboard: p=2 c=Editing
Whiteboard: [specification-like][type:bug][selected]
Priority: P1 → P2
Whiteboard: [specification-like][type:bug][selected] → [specification-like][type:bug]
Whiteboard: [specification-like][type:bug] → [type:bug]
Are we missing important docs here?  It's a year and a half down the road...
(In reply to David Walsh :davidwalsh from comment #9)
> Are we missing important docs here?  It's a year and a half down the road...

Yes, and we occasionally still get asked about them. Same pages that are listed in c#0.
This is likely a result of bug 1090241.
Assignee: nobody → jezdez
Status: NEW → ASSIGNED
Depends on: 1090241
Not quite, but this gets us closer, further investigating..
(In reply to potappo from comment #0)
> The following pages are missing.
> 
> C++ Portability Guide
> https://developer.mozilla.org/en/C%2B%2B_Portability_Guide

This is fixed now, after fixing an encoding issue in the database content.
See https://developer.mozilla.org/en/C++_Portability_Guide

> DebugOnly<T>
> https://developer.mozilla.org/en/Namespace/Mozilla/DebugOnly%3CT%3E

The document was deleted, I restored it.

> Another example:
> 
> PKCS #11 Netscape Trust Objects
> https://developer.mozilla.org/en/NSS/PKCS_%2311_Netscape_Trust

Restored as https://developer.mozilla.org/en-US/docs/NSS/PKCS_11_Netscape_Trust

There was some problems with storing the # sign in the database
I'm closing this as fixed since I've looked into the documents listed above. Feel free to reopen if there are other documents that require fixing.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.