Last Comment Bug 780387 - Don't use unnecessary PR* typedefs
: Don't use unnecessary PR* typedefs
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-04 07:22 PDT by :Ms2ger (⌚ UTC+1/+2)
Modified: 2012-08-17 09:24 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Part a: PRPtrdiff (2.47 KB, patch)
2012-08-04 07:24 PDT, :Ms2ger (⌚ UTC+1/+2)
benjamin: review+
Ms2ger: checkin+
Details | Diff | Splinter Review
Part b: PRIntn (121.12 KB, patch)
2012-08-04 07:25 PDT, :Ms2ger (⌚ UTC+1/+2)
benjamin: review+
Ms2ger: checkin+
Details | Diff | Splinter Review
Part c: PRUintn (26.53 KB, patch)
2012-08-04 07:25 PDT, :Ms2ger (⌚ UTC+1/+2)
benjamin: review-
Details | Diff | Splinter Review
Part d: PRFloat64 (13.40 KB, patch)
2012-08-04 07:26 PDT, :Ms2ger (⌚ UTC+1/+2)
benjamin: review+
Ms2ger: checkin+
Details | Diff | Splinter Review
Part e: PRSize (15.28 KB, patch)
2012-08-04 07:26 PDT, :Ms2ger (⌚ UTC+1/+2)
benjamin: review+
Ms2ger: checkin+
Details | Diff | Splinter Review
Part f: PRBool / PRPackedBool (2.01 KB, patch)
2012-08-04 07:29 PDT, :Ms2ger (⌚ UTC+1/+2)
benjamin: review+
Ms2ger: checkin+
Details | Diff | Splinter Review
Sample script (604 bytes, text/plain)
2012-08-04 07:33 PDT, :Ms2ger (⌚ UTC+1/+2)
no flags Details
Part c: PRUintn (v2) (15.24 KB, patch)
2012-08-08 11:09 PDT, :Ms2ger (⌚ UTC+1/+2)
no flags Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2012-08-04 07:22:53 PDT
There is very little point in using, say |typedef size_t PRSize;| when we can use size_t directly.
Comment 1 :Ms2ger (⌚ UTC+1/+2) 2012-08-04 07:24:32 PDT
Created attachment 648992 [details] [diff] [review]
Part a: PRPtrdiff
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2012-08-04 07:25:18 PDT
Created attachment 648993 [details] [diff] [review]
Part b: PRIntn
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2012-08-04 07:25:41 PDT
Created attachment 648994 [details] [diff] [review]
Part c: PRUintn
Comment 4 :Ms2ger (⌚ UTC+1/+2) 2012-08-04 07:26:12 PDT
Created attachment 648995 [details] [diff] [review]
Part d: PRFloat64
Comment 5 :Ms2ger (⌚ UTC+1/+2) 2012-08-04 07:26:36 PDT
Created attachment 648996 [details] [diff] [review]
Part e: PRSize
Comment 6 :Ms2ger (⌚ UTC+1/+2) 2012-08-04 07:29:14 PDT
Created attachment 648997 [details] [diff] [review]
Part f: PRBool / PRPackedBool

Turns out those keep sneaking in.
Comment 7 :Ms2ger (⌚ UTC+1/+2) 2012-08-04 07:33:24 PDT
Created attachment 648998 [details]
Sample script

Parts b-e were generated with a shell script stolen from the prbool bug like this one.
Comment 8 Benjamin Smedberg [:bsmedberg] 2012-08-08 10:54:06 PDT
Comment on attachment 648994 [details] [diff] [review]
Part c: PRUintn

I don't think we should do this for the cases which are using PR_NewThreadPrivateIndex, which still uses PRUintn*.
Comment 9 :Ms2ger (⌚ UTC+1/+2) 2012-08-08 11:09:25 PDT
Created attachment 650211 [details] [diff] [review]
Part c: PRUintn (v2)

I think I caught them all.
Comment 10 :Ms2ger (⌚ UTC+1/+2) 2012-08-09 04:01:10 PDT
Comment on attachment 648992 [details] [diff] [review]
Part a: PRPtrdiff

https://hg.mozilla.org/mozilla-central/rev/62d94d3c6aff
Comment 11 :Ms2ger (⌚ UTC+1/+2) 2012-08-09 04:01:29 PDT
Comment on attachment 648993 [details] [diff] [review]
Part b: PRIntn

https://hg.mozilla.org/mozilla-central/rev/4587cc2d0154
Comment 12 :Ms2ger (⌚ UTC+1/+2) 2012-08-09 04:01:46 PDT
Comment on attachment 648995 [details] [diff] [review]
Part d: PRFloat64

https://hg.mozilla.org/mozilla-central/rev/25378953c584
Comment 13 :Ms2ger (⌚ UTC+1/+2) 2012-08-09 04:02:03 PDT
Comment on attachment 648996 [details] [diff] [review]
Part e: PRSize

https://hg.mozilla.org/mozilla-central/rev/44fe712a01c8
Comment 14 :Ms2ger (⌚ UTC+1/+2) 2012-08-09 04:02:18 PDT
Comment on attachment 648997 [details] [diff] [review]
Part f: PRBool / PRPackedBool

https://hg.mozilla.org/mozilla-central/rev/5b0ac8d41b80
Comment 15 Benjamin Smedberg [:bsmedberg] 2012-08-17 09:23:27 PDT
Comment on attachment 650211 [details] [diff] [review]
Part c: PRUintn (v2)

I understand this to have been subsumed by bug 579517, which I hope to get to shortly.
Comment 16 :Ms2ger (⌚ UTC+1/+2) 2012-08-17 09:24:41 PDT
The parts we're going to fix in this bug are fixed, then.

Note You need to log in before you can comment on or make changes to this bug.