enh: "Open All in 1 Tab" - menu item to pre-fill history with user-specified bookmark collection

RESOLVED DUPLICATE of bug 837364

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED DUPLICATE of bug 837364
6 years ago
6 years ago

People

(Reporter: Ken Winiecki, Jr., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I propose a bookmarks UI enhancement where the "Open All in Tabs" menu item, seen when right-clicking a set or folder of bookmarks anywhere and when clicking a folder of bookmarks in a toolbar, would be accompanied by something like an "Open All in 1 Tab" menu item.

It wouldn't actually load all the bookmarks, only the firstmost bookmark; all the other bookmarks it would place into that tab's history for Forward (and then Back) button navigation, flagged as not-yet-loaded so that the first navigation to each one would trigger its loading.

Currently, most (though not all) of my bookmark folders I "Open All in Tabs" only because there is no other way to avoid both navigating menus to individual bookmarks and losing display width to the bookmarks sidebar.  But I don't actually need them concurrently, I only intend to use and discard them sequentially, so I also don't need them loading simultaneously and consuming all the tab bar, CPU, network, and UI responsiveness.  Navigating bookmark collections with the Forward and Back buttons in a single tab with load-on-demand would resolve this perfectly I think.

I don't permit session data to be retained, so disk cache and session/history restore features are not of direct benefit.

It might also help slightly reduce the need for enhancement bug 756807 .
how would you present this to the user to make clear what happened, if he can just see the first bookmark being loaded and maybe the forward button enabled, it won't be clear at all what happened.
(Reporter)

Comment 2

6 years ago
One way might be to automatically pop up the forward-button-right-click history menu for a short period of time and then automatically close it.

A second way might be to invent a new indicator in the tab consisting of a horizontal row of dots or dashes either at the top or bottom edge of the tab equal to the tab's number of history items, and highlight the dot representing the current history entry being shown.  Actually this would be handy to have regardless.  The dots could even be clickable to go to that point in the history.  And/or they could have a tooltip.

A third way might be to invent a new icon to appear in the tab either to the left or right of the favicon or left of the closebutton, which could have a tooltip and/or make the forward-button-right-click history menu appear while mousedown.
(Reporter)

Comment 3

6 years ago
A fourth way might be to enhance the history sidebar (or invent a new additional one) and automatically show that.  Currently the minimum width of the history sidebar appears to be the width of a small search text field plus a small sort button, around 148 pixels.  Create 2 narrower (flattened) user-selectable widths that can be snapped-to using the width-dragger, one the width of the favicon and another the width of a (narrower) dot or vertical bar.
(Reporter)

Comment 4

6 years ago
After trying out the existing history sidebar, the 4th method won't work with it, so it would have to be a new form of history sidebar.  The existing history sidebar does not show only the forward tab history, and does not use a separate width parameter from the bookmark sidebar.

Comment 5

6 years ago
Overriding back/history sounds confusing.  And fragile, because you lose your forward history whenever you click a link.

I'd prefer deferred-load tabs (bug 837364).  Would that work for you, Ken?
(Reporter)

Comment 6

6 years ago
> lose your forward history whenever you click a link

Ah, yes...I'd forgotten that I'd formed the habit of only command-clicking links specifially to avoid that.

> deferred-load tabs (bug 837364).  Would that work

I...think...yes!  In fact, that's much better than what I was thinking was necessary.  I'm marking this resolved and going to vote for that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 837364
You need to log in before you can comment on or make changes to this bug.