null element being passed to BrowserEventHandler._sendMouseEvent

RESOLVED DUPLICATE of bug 779920

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 779920
6 years ago
6 years ago

People

(Reporter: Margaret, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
[JavaScript Error: "aElement is null" {file: "chrome://browser/content/browser.js" line: 3544}]

In my build, that corresponds to this line in BrowserEventHandler._sendMouseEvent:
let window = aElement.ownerDocument.defaultView;

Which sounds like we're getting a null element in the Gesture:SingleTap handler.

This isn't killing the browser, but we probably want to investigate why this is happening.
It's a legitimate bug that is preventing tapping on things in iframes :(
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 779920
You need to log in before you can comment on or make changes to this bug.