when beforeunload event is executed, user string is not shown anymore

RESOLVED DUPLICATE of bug 641509

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 641509
6 years ago
6 years ago

People

(Reporter: Oleg, Unassigned)

Tracking

6 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110811165603

Steps to reproduce:

When register handler for beforeunload event – 
window.onbeforeunload = function() {
return "bla";
}

or through addEventListener – 
window.addEventListener( "beforeunload", function( event ) {
event.returnValue = "bla";
return "bla";
});



Actual results:

when beforeunload is fired, "bla" is not shown in dialog box.


Expected results:

"bla" should be shown in dialog box
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 641509
You need to log in before you can comment on or make changes to this bug.