Last Comment Bug 780462 - Stop removing dist/bin/components when starting a build
: Stop removing dist/bin/components when starting a build
Status: RESOLVED FIXED
[buildfaster:?]
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla19
Assigned To: Mike Hommey [:glandium]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-05 04:24 PDT by Mike Hommey [:glandium]
Modified: 2012-10-16 01:28 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Don't remove dist/bin/components when building, but remove dist/bin/chrome.manifest (1.11 KB, patch)
2012-08-05 04:25 PDT, Mike Hommey [:glandium]
khuey: review+
Details | Diff | Splinter Review
Actually remove dist/bin/chrome.manifest when starting a new build (1.10 KB, patch)
2012-10-11 00:34 PDT, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
Actually remove dist/bin/chrome.manifest when starting a new build, and also remove dist/bin/components/components.manifest (1.19 KB, patch)
2012-10-11 03:42 PDT, Mike Hommey [:glandium]
khuey: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2012-08-05 04:24:20 PDT
As said in http://gregoryszorc.com/blog/2012/07/29/mozilla-central-build-times/ comments by Neil Rashbrook, we've had manifests for two years.

However, as a consequence, we should remove the top chrome.manifest, because otherwise components that are removed from the tree but still in dist/bin/components because they were not rm -rfed at the beginning of the build, would still be registered.
Comment 1 Mike Hommey [:glandium] 2012-08-05 04:25:19 PDT
Created attachment 649092 [details] [diff] [review]
Don't remove dist/bin/components when building, but remove dist/bin/chrome.manifest
Comment 2 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-08-07 11:54:09 PDT
Comment on attachment 649092 [details] [diff] [review]
Don't remove dist/bin/components when building, but remove dist/bin/chrome.manifest

Review of attachment 649092 [details] [diff] [review]:
-----------------------------------------------------------------

Mildly scary, but ok.
Comment 4 Ed Morley [:emorley] 2012-08-08 09:27:34 PDT
https://hg.mozilla.org/mozilla-central/rev/fda1cd4d7dba
Comment 5 Mike Hommey [:glandium] 2012-10-11 00:33:36 PDT
D'oh. The patch was wrong.
Comment 6 Mike Hommey [:glandium] 2012-10-11 00:34:09 PDT
Created attachment 670283 [details] [diff] [review]
Actually remove dist/bin/chrome.manifest when starting a new build

Oops. Didn't quite do what it was intended to do.
Comment 7 Mike Hommey [:glandium] 2012-10-11 03:42:38 PDT
Created attachment 670332 [details] [diff] [review]
Actually remove dist/bin/chrome.manifest when starting a new build, and also remove dist/bin/components/components.manifest

While at it...
Comment 9 Ed Morley [:emorley] 2012-10-16 01:28:02 PDT
https://hg.mozilla.org/mozilla-central/rev/9ca0df7f08fc

Note You need to log in before you can comment on or make changes to this bug.