Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Pymake: avoid spawning shell processes while compiling

RESOLVED FIXED in mozilla17

Status

()

Core
Build Config
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sid0, Assigned: sid0)

Tracking

(Blocks: 1 bug)

Trunk
mozilla17
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Created attachment 649131 [details] [diff] [review]
patch v1

Two improvements:
1. In silent mode, we hook in an ELOG because GNU make doesn't print the command that failed. Pymake does, so the hook just creates unnecessary shell processes.
2. REPORT_BUILD causes a shell invocation for every single file build, and it can simply be replaced with $(info) since it's always the first command in a recipe.
Attachment #649131 - Flags: review?(khuey)
(Assignee)

Comment 1

5 years ago
This seems to speed up builds by around 2 minutes (4-5%) on my computer.
(Assignee)

Comment 2

5 years ago
Created attachment 649132 [details] [diff] [review]
patch to comm-central v1
Attachment #649132 - Flags: review?(ted.mielczarek)
(Assignee)

Updated

5 years ago
Attachment #649132 - Flags: review?(ted.mielczarek) → review?(khuey)
(Assignee)

Updated

5 years ago
Blocks: 585011
Comment on attachment 649131 [details] [diff] [review]
patch v1

Review of attachment 649131 [details] [diff] [review]:
-----------------------------------------------------------------

Haha, nice.
Attachment #649131 - Flags: review?(khuey) → review+
Attachment #649132 - Flags: review?(khuey) → review+
(Assignee)

Comment 4

5 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/5804800a7009

I still need to check in the comm-central patch.
Whiteboard: [leave open]

Comment 5

5 years ago
Bug 602494 seems to be a duplicate of this bug.
(Assignee)

Updated

5 years ago
Duplicate of this bug: 602494
(Assignee)

Comment 7

5 years ago
Thanks Ziga, didn't know about it.
https://hg.mozilla.org/mozilla-central/rev/5804800a7009
Blocks: 602492
(Assignee)

Comment 9

5 years ago
http://hg.mozilla.org/comm-central/rev/914c29a1a1e3
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla17

Updated

5 years ago
Whiteboard: [leave open]
You need to log in before you can comment on or make changes to this bug.