The new "plugins.click_to_play" setting doesn't work consistently.

RESOLVED INVALID

Status

()

Core
Plug-ins
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Andy Fielding, Unassigned)

Tracking

13 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:13.0) Gecko/20120606 Firefox/13.0
Build ID: 20120606130836

Steps to reproduce:

Set the new "plugins.click_to_play" setting to True.


Actual results:

This is supposed to prevent plugin media (e.g. Flash) from playing until you click them.

Unfortunately, it doesn't work consistently. On this page:

http://ioechomusic.com/

...the "click here" text appeared, but clicking had no effect and the media couldn't be viewed.


Expected results:

(You can probably figure that out.)

Comment 1

6 years ago
Created attachment 649221 [details]
Screenshot FF14/FF17

You should update to Firefox 14 because some click-to-play bugs have been fixed since Firefox 13 (and in the next versions too).

Anyway I tried with FF14/FF17 (see my attached screenshot) and it works fine even if FF14 blocks the JS/Flash sound component of Soundcloud (not the case in FF17).

In FF14, clicking on the blocked Youtube video OR the blocked Soundcloud manager enables the media.
In FF17, clicking on the blocked Youtube video enables the media (clicking on the visible Soundcloud manager doesn't do anything).

Therefore, I don't see a wrong behavior here.

Updated

6 years ago
Blocks: 738698
Component: Untriaged → Plug-ins
Product: Firefox → Core
(Reporter)

Comment 2

6 years ago
Ah, great. Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.