Closed Bug 780563 Opened 9 years ago Closed 8 years ago

m.welt.de sends wannabe WAP/XHTML content, causes XML syntax error

Categories

(Web Compatibility :: Mobile, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: r.brommauer, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

Want to read the mobile homepage "m.welt.de" 


Actual results:

Got the message
"XML-Verarbeitungsfehler: nicht wohlgeformt
Adresse: http://m.welt.de/
Zeile Nr. 32, Spalte78:
mm.src = "http://www.welt.de/user-mobil3/js/bigp_overlay_mobile.js?v=1&config=";"

In firefox for windows v14.0 it works.


Expected results:

The page m.welt.de should be shown
This is a site issue. They are user-agent detecting and failing in their detection code with what looks like a non-existant script or script error. They should do proper testing, and accept our user-agent.
Status: UNCONFIRMED → NEW
Component: General → Evangelism
Ever confirmed: true
OS: Windows 7 → Android
Hardware: x86_64 → ARM
Summary: error message when entering to "m.welt.de" → [meta] - Issues with m.welt.de
Whiteboard: [meta]
Version: Firefox 15 → Trunk
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism
Version: Trunk → unspecified
Summary: [meta] - Issues with m.welt.de → m.welt.de sends wannabe WAP/XHTML content, causes XML syntax error
Whiteboard: [meta]
I can not reproduce now - works fine in both Fx on Android and FxOS.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.