Last Comment Bug 780582 - Text gets selected just by hovering the mouse over
: Text gets selected just by hovering the mouse over
Status: RESOLVED FIXED
: regression, reproducible
Product: Core
Classification: Components
Component: Selection (show other bugs)
: unspecified
: x86 Windows 7
: -- normal (vote)
: mozilla17
Assigned To: Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
: Simona B [:simonab]
Mentors:
Depends on:
Blocks: 761572
  Show dependency treegraph
 
Reported: 2012-08-06 04:30 PDT by Simona B [:simonab]
Modified: 2014-01-10 10:39 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
wontfix
+
verified
+
verified


Attachments
fix (1.19 KB, patch)
2012-08-06 22:36 PDT, Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
bugs: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Review

Description Simona B [:simonab] 2012-08-06 04:30:10 PDT
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0

While verifying Bug 761572 I stumbled upon this issue.

Reproducible: always

Steps to reproduce:
1. Navigate to https://bug761572.bugzilla.mozilla.org/attachment.cgi?id=630142
2. Click on the 'Set display to none' button
3. Move the mouse over the text without clicking on anything.

Expected results:
The background text doesn't get selected. 

Actual results:
The background text gets selected. After hitting the OK button from the prompt displayed in step 2 the issue doesn't reproduce.
Comment 1 Alice0775 White 2012-08-06 05:21:21 PDT
#1  Alert box does not  pop up
#2  Fixed #1, but selection problem happens 

#1 Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/f6d082275253
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120530012752
Bad(Alert box does not  pop up):
http://hg.mozilla.org/mozilla-central/rev/b5af439f1717
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120530042453
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f6d082275253&tochange=b5af439f1717

#1 Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/cfd001299d34
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120529021158
Bad(Alert box does not  pop up):
http://hg.mozilla.org/integration/mozilla-inbound/rev/d0beb7e43cc4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120529061423
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=cfd001299d34&tochange=d0beb7e43cc4
#1 Suspected: Bug 758179


#2 Regression window(m-c)
Bad(Alert box does not  pop up):
http://hg.mozilla.org/mozilla-central/rev/5891cc95eac7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120607140205
Bad(Fixed #1, but selection problem happens ):
http://hg.mozilla.org/mozilla-central/rev/22bb7d46bb23
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120608081921
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5891cc95eac7&tochange=22bb7d46bb23


#2 Regression window(m-i)
Bad(Alert box does not  pop up):
http://hg.mozilla.org/integration/mozilla-inbound/rev/5a1dc5b1ecbb
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120607014319
Bad(Fixed #1, but selection problem happens ):
http://hg.mozilla.org/integration/mozilla-inbound/rev/4f28fd1e2d81
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120607030819
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5a1dc5b1ecbb&tochange=4f28fd1e2d81
#2 Suspected: Bug 761572
Comment 2 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-06 15:06:43 PDT
Assigning to roc to take a look, since bug 761572 is being fingered as the potential culprit here, tracking as well for being a 15 regression, would be great to never ship this.
Comment 3 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-08-06 18:05:23 PDT
I'll work on this, but I don't think we should worry about it for FF15. It's a minor bug that only happens in situations where we were completely broken before (i.e. in the testcase, the alert box not popping up).
Comment 4 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-08-06 22:36:42 PDT
Created attachment 649543 [details] [diff] [review]
fix

This fixes it.

I haven't been able to find a good way to test this. For some reason the alert() is needed; without it, nsFrame::HandleRelease isn't called, but somehow mouse movement stops selecting anyway.
Comment 5 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-08-07 04:08:57 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/d75263064dc5
Comment 6 Ed Morley [:emorley] 2012-08-08 09:36:19 PDT
https://hg.mozilla.org/mozilla-central/rev/d75263064dc5
Comment 7 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-08-09 17:54:24 PDT
Comment on attachment 649543 [details] [diff] [review]
fix

Review of attachment 649543 [details] [diff] [review]:
-----------------------------------------------------------------

So far so good. I think this is plenty safe enough for Aurora.
Comment 8 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-10 09:02:20 PDT
This was a regression in 15 and even if the instances of it occurring are rare-ish, it's still nice to never ship something like this that users will run up against and be frustrated by - do you think this is low-risk enough to take before our next Beta?
Comment 9 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-10 09:04:53 PDT
(In reply to Lukas Blakk [:lsblakk] from comment #8)
> This was a regression in 15 and even if the instances of it occurring are
> rare-ish, it's still nice to never ship something like this that users will
> run up against and be frustrated by - do you think this is low-risk enough
> to take before our next Beta?

Just got info from roc in email and I agree with him that this bug is not important enough to take so late in Beta, see comment 3 as well.
Comment 10 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-20 16:43:53 PDT
This still needs to land on Aurora, wontfixing for FF15.
Comment 11 Ryan VanderMeulen [:RyanVM] 2012-08-20 17:32:32 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/65ac00871b6e
Comment 12 Simona B [:simonab] 2012-09-21 01:35:51 PDT
Verified on Firefox 16 beta 4 that the text does not get selected anymore when hovering the mouse over (used the test case from the Description).
Mozilla/5.0 (Windows NT 6.1; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20120919065210
Comment 13 Simona B [:simonab] 2012-10-16 09:08:15 PDT
Verified as fixed on Firefox 17 beta 1 - the text does not get selected when hovering the mouse over.
Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/17.0 Firefox/17.0
Comment 14 Tracy Walker [:tracy] 2014-01-10 10:39:22 PST
mass remove verifyme requests greater than 4 months old

Note You need to log in before you can comment on or make changes to this bug.