If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

no keyboard (menu) access to insert-smiley feature

VERIFIED FIXED in mozilla1.1beta

Status

MailNews Core
Composition
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: Jesse Ruderman, Assigned: varada)

Tracking

({access, sec508})

Trunk
mozilla1.1beta
x86
Windows 98
access, sec508

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 3 obsolete attachments)

(Reporter)

Description

17 years ago
Most of the toolbar buttons in message compose have menu equivalents, but the 
insert-smiley feature doesn't.  This means there's no way to insert a graphical 
smiley using the keyboard :(

(Filing against Editor instead of Message Composition because I think this 
feature is also used in IM, and because bug 66213 is in the Editor component.)
(Reporter)

Updated

17 years ago
Keywords: access

Comment 1

17 years ago
This should go to anatoliya@aol.com.
Assignee: beppe → anatoliya

Comment 2

17 years ago
Created attachment 32665 [details] [diff] [review]
added smiley to editor

Comment 3

17 years ago
Please r/sr.
Status: NEW → ASSIGNED

Comment 4

17 years ago
Anatoliy, this bug isn't requesting that smileys be added to Composer. I think 
it was already decided that we shouldn't be adding smileys to Composer.

This bug is about the fact that most of the items on MsgCompose's toolbar are 
also under the main menus ... smileys are only available via the toolbar. The 
user is also requesting that keyboard shortcuts for the various smileys be 
added.

Comment 5

17 years ago
Anatoliy does not yet need r= or sr=.  He is working on a new fix which will add 
accessibility but not add the smiley feature to Composer.

This is really an accessibility bug and should be in Keyboard Navigation (not 
Editor).

Jesse--are you suggesting that the insert smiley menu should be a hierarchical 
menu below the insert menu?
Component: Editor → Keyboard Navigation

Comment 6

17 years ago
No! We don't wan't the "Smiley" button on the toolbar.
Adding it as a submenu under "Insert" is acceptable.
(Reporter)

Comment 7

17 years ago
Yes, there should be a submenu or menu item for inserting smilies in the Insert 
menu of the Message Compose window.  This shouldn't be necessary in a normal 
Composer window, since smilies are only supported in messages anyway.

Would using a submenu (as opposed to a menu item that brings up a dialog) only 
allow the text descriptions of the smilies to be shown, or do Mozilla's menus 
support large icons?

Comment 8

16 years ago
Keyboard access to all features is a requirement for Mozilla-based products to
be sold to the goverment.
Severity: minor → normal
Keywords: fcc508

Comment 9

16 years ago
does the reg require that people be able to trigger things the same exact way?

if users can insert smilies using the keyboard i don't quite understand why we 
need to let them activate a dropdown widget (although i wouldn't oppse support 
for tabbing through toolbars).

Comment 10

16 years ago
Well, it's a feature that you can choose the smiley based on a named emotion.
That feature is not available.

I suppose it could slide on the technicality though.

Comment 11

16 years ago
removing myself from the cc list

Comment 12

16 years ago
Created attachment 84118 [details] [diff] [review]
Add Smiley face menu after Insert/HTML in HTML message compose

Updated

16 years ago
Keywords: patch, review

Comment 13

16 years ago
Is there any Mozilla app which sends/saves these *graphical* smilies? If not, we
have an easy and intuitive keyboard access: Type ":-)".

Even if some Mozilla app sends graphical smilies (Mailnews surely does not), I
don't think that anybody limited to keyboard is keen on using them. Text-only
smilies are so commonplace and so much faster and more convient to type that I
don't think that anybody used to the keyboard will bother about graphical smilies.

In fact, I think don't understand why we have these graphical smilies at all.
Anyways, adding a submenu just so we can add key accelerators sounds quite silly
to me. As if we didn't have enough menus already.

As for government requirements, I'd argue that text-only smilies do it, for the
above reason.

Comment 14

16 years ago
Aaron--would you prefer Neil's patch or Ben's argument?  If you prefer Ben's
argument, we should resolve this bug as wontfix.

Comment 15

16 years ago
I think Ben's argument makes sense, except in IM (I know, this is not in
Mozilla). In IM we already have the menu, which contains a list of emotions that
you can pick from. In other words, if there is already a menu available for
mouse users, it should also be available from the keyboard. If there is not, we
can leave it alone.

On the other hand, can anyone name off the different ascii equivalents for the
different emotions we support? Are they actually listed anywhere?

Comment 16

16 years ago
aim 4.8.2646
:-) =-O :-$ :-\
:-( :-* :-! :'(
;-) >:o :-[ :-X
:-P 8-) O:-) :-D
procedure: load aim, click each smily, copy to nc4
as for giving friendly names ... um

the following is subject to analysis or negotation
) smile
( frown
; wink
P thpbbt
= startled
* smoking
> shocked
8 cool
$ scared
! surprised
[ toungue biting
0 angelic
\ disappointed
' crying
X silenced
D happy toungue

Comment 17

16 years ago
For IM or email it isn't suitable. Because it must be compatible with another 
IM clients (they are not Netscape or Mozilla).
So, we need to support 3-char sequences.

Comment 18

16 years ago
I've found that :-D is typically "Yay" and ":-/" is typically "worried"

In some communities, :-X or :-* is kiss, in others it's silence & smoking as
mentioned.

Comment 19

16 years ago
comment 17 is cryptic. what in the world was it in reference to?

my single character prefixes where for accesskeys for a menu which had the 
smilies listed previously.

Updated

16 years ago
Depends on: 145951
(Reporter)

Comment 20

16 years ago
For Instant Messenger: http://bugscape.netscape.com/show_bug.cgi?id=11804,
"Can't access smiley menu via keyboard (Menus or shortcuts)".

Comment 21

15 years ago
*** Bug 155104 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 22

15 years ago
Re-assigning bug to varada
Assignee: anatoliya → varada
Status: ASSIGNED → NEW
Component: Keyboard Navigation → Composition
Product: Browser → MailNews
Target Milestone: --- → mozilla1.1beta
(Assignee)

Comment 23

15 years ago
Created attachment 91878 [details] [diff] [review]
Editor part of patch

Importing patch from 155104
Attachment #32665 - Attachment is obsolete: true
Attachment #84118 - Attachment is obsolete: true
(Assignee)

Comment 24

15 years ago
Created attachment 91879 [details] [diff] [review]
MailCompose portion of patch

Mailcompose portion of patch
Comment on attachment 91878 [details] [diff] [review]
Editor part of patch

R=ducarroz
Attachment #91878 - Flags: review+
Comment on attachment 91879 [details] [diff] [review]
MailCompose portion of patch

missing the diff for the jar file (and maybe the .in file to) Appart that,
R=ducarroz
Attachment #91879 - Flags: review+
(Assignee)

Comment 27

15 years ago
Created attachment 91881 [details] [diff] [review]
changes to jar.mn

Changes to jar and there is no Makefile.in there.
Comment on attachment 91881 [details] [diff] [review]
changes to jar.mn

R=ducarroz
Attachment #91881 - Flags: review+

Comment 29

15 years ago
Comment on attachment 91879 [details] [diff] [review]
MailCompose portion of patch

Where are your entities?
I don't see insertSmiley.label defined anywhere. Also while the
smileyNCmd.label entities have definitions in editorOverlay.dtd you are trying
to use messengercompose.dtd which does not define them.
Attachment #91879 - Flags: needs-work+
(Assignee)

Comment 30

15 years ago
Created attachment 91962 [details] [diff] [review]
Changes to dtd files

Localization Changes for smiley menu items.

Comment 31

15 years ago
has anyone one the UE team looked at the new strings? cc'ing Jennifer.
(Assignee)

Comment 32

15 years ago
Moving comments from DUP bug #155104.
------- Additional Comment #2 From jglick@netscape.com 2002-07-01 10:27 -------

Add "_S_miley" to the Insert Menu below "Characters and Symbols".

Flyout smiley menu:
_S_mile
_F_rown
_W_ink
_T_ongue-out
_L_aughing
_E_mbarrassed
_U_ndecided

Comment 33

15 years ago
>Additional Comment #30 From varada@netscape.com 2002-07-19 09:44
>Created an attachment (id=91962)
>Changes to dtd files

Looks good.
Only comment, are you adding the tooltip:
+<!ENTITY SmileButton.tooltip "Choose smiley face">
If so, can it say "Insert a smiley face" instead?
(Assignee)

Comment 34

15 years ago
Created attachment 95653 [details] [diff] [review]
Changes to dtd files v1.1

Changed the tooltip wording as per Jennifer's suggestions.
Attachment #91962 - Attachment is obsolete: true

Comment 35

15 years ago
Comment on attachment 95653 [details] [diff] [review]
Changes to dtd files v1.1

sr=bienvenu
Attachment #95653 - Flags: superreview+
(Assignee)

Comment 36

15 years ago
Marking Fixed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 37

15 years ago
verified 
Status: RESOLVED → VERIFIED
QA Contact: sujay → gbush
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.