Closed Bug 780697 Opened 8 years ago Closed 8 years ago

incorrect spacing with Graphite rendering

Categories

(Core :: Layout: Text and Fonts, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 772640

People

(Reporter: eusgf4u4pw, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

Enable Graphite rendering by going to about:config and setting gfx.font_rendering.graphite.enabled true.

With Scheherazade font (in development -- contains both OpenType and Graphite logic) installed, open and display YehSequences.htm file.  (both files in attached zip)

Verify "check" line says "RenderingGraphite" -- this confirms that Firefox is using Graphite rather than OpenType rendering.

Each run of Arabic is identical except for the first character of the middle word. Each run is 3 "words" separated by space (U+0020), the first and last words are single characters (U+0628). 

Note glyph spacing for tests labeled "U+064A" and "U+06D1".


Actual results:

For U+064A and U+06D1 tests, the middle word overlaps the 3rd word --the space is  completely missing. There is also a gap between two letters of middle word.  See annotated attachment.


Expected results:

The spacing of all runs of Arabic should be the same. Set gfx.font_rendering.graphite.enabled false to see correct spacing. Or render Graphite text in LibreOffice Writer.
Attached image Shows incorrect spacing
Fails on release 14.0.1 and nightly 17.0a1 (2012-08-06).

I first suspected hinting, but I have stripped all hints from this font and the results are the same.

Bob
Same behavior on Ubuntu 11.10 with Firefox 14.0.1.  (Didn't try nightly)
I notice that in the "problem" lines, the initial glyph seems to have been replaced by an elongated form (to avoid the dots below clashing with the tail of yeh) - or is there a kashida-like glyph being inserted, or a positioning adjustment applied? It seems like this is somehow causing us to mishandle the glyph positioning data.

Presumably, those two lines ought to be slightly wider than the other four, because of the extension of the <initial>-yeh join, but the inter-word spacing obviously should be the same.

This may well turn out to be the same underlying problem as bug 772640, but until we figure out exactly where it's going wrong, that's only a guess.
Well spotted Jonathan. I thought the kashida insertion had been turned off long ago, but it is still there waiting for me to update it.

So this is looking more like it could be a duplicate of bug 772640 -- I'll await your work on that one.
Closing as duplicate on the basis of bug 772640 comment 7.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 772640
You need to log in before you can comment on or make changes to this bug.