Closed Bug 78072 Opened 19 years ago Closed 12 years ago

Mozilla should re-read bookmarks.html if it has been changed by another process

Categories

(SeaMonkey :: Bookmarks & History, defect, P5)

x86
Linux
defect

Tracking

(Not tracked)

RESOLVED WONTFIX
Future

People

(Reporter: burton, Unassigned)

References

Details

If I am using another process/application to manage my bookmarks Mozilla
currently isn't smart enough to re-read bookmarks.html.  This means that any
changes done via a third party application are destroyed when Mozilla is quit.  

Mozilla should uses select(2) and if the file has been changed on disk it should
reread it.
Netscape 4 will ask the user, upon detecting changes to the bookmark file,
"Bookmarks have changed on disk. Discard your unsaved changes and reload?"

I suggest Mozilla to follow suit.
Keywords: 4xp
confirming...
Status: UNCONFIRMED → NEW
Ever confirmed: true
I entirely agree on this one.  The current behavior interacts quite badily with
applications such as unison that synchronize files over multiple machines. 
Really, it interacts badly with any application that modifies bookmarks.
Status: NEW → ASSIGNED
Target Milestone: --- → Future
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW
Mass move Ben's bugs dumped on me marked future with p5 to get off my untriaged
radar. You can filter out this email by looking for "ironstomachaussie"
Priority: -- → P5
This is a great idea. I'd like to see it moved up in priority, as it takes some
of the pressure off of highly-requested-but-non-trivial bug #17048.

I've got several, though.

First, this should apply to cookies and other files as well as bookmarks,
although bookmarks are the most important.

Second, I found Netscape Communicator's behavior very annoying -- there was
never really any clue as to whether the change should be accepted or not. And,
if this were used as part of some automated sync process, the dialog would be
annoying. If people want the interruption, it should be an option and off by
default (or a dialog with a "don't show this again" checkbox).

Also, another key part of this is that when Mozilla makes its own changes, it
should write them out immediately. That's a bit more complicated, though.
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben
People interested in this bug might want to note bug #124048.
*** Bug 129065 has been marked as a duplicate of this bug. ***
See also bug 208641, same bug for userContent.css.
Product: Browser → Seamonkey
Assignee: bugs → nobody
QA Contact: claudius → bookmarks
We will be moving to places backend (sqlite) on trunk and bookmarks.html will be abandoned.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.