[B2G] test_audio1.html | We expected 'tests/content/media/test/320x240.ogv' to exist, but it doesn't!

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: jgriffin, Unassigned)

Tracking

({intermittent-failure})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Several content/media mochitests fail on B2G, with errors similar to:

TEST-UNEXPECTED-FAIL | We expected 'tests/content/media/test/320x240.ogv' to exist, but it doesn't!
TEST-UNEXPECTED-FAIL | We expected 'tests/content/media/test/r11025_s16_c1.wav' to exist, but it doesn't!
TEST-UNEXPECTED-FAIL | We expected 'tests/content/media/test/bug461281.ogg' to exist, but it doesn't!
TEST-UNEXPECTED-FAIL | We expected 'tests/content/media/test/seek.webm' to exist, but it doesn't!
TEST-UNEXPECTED-FAIL | an unexpected uncaught JS exception reported through window.onerror - NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIPrefBranch.setIntPref] at http://mochi.test:8888/tests/content/media/test/manifest.js:518

Affected tests are at least:

/tests/content/media/test/test_audio1.html
/tests/content/canvas/test/crossorigin/test_video_crossorigin.html
/tests/content/media/test/test_audio2.html
/tests/content/media/test/test_access_control.html

For instructions on running mochitests on B2G emulators see https://developer.mozilla.org/en-US/docs/Mozilla/Boot_to_Gecko/B2G_Mochitests
(Reporter)

Updated

7 years ago
(Reporter)

Comment 2

7 years ago
These tests have started timing out, and so need to be disabled.  This happened sometime since http://github.com/mozilla/mozilla-central/commit/9f4e1d00dfa611a3f0ec30a9fcbf6564cd9d39cf, but this timeout was masked by timeouts in other tests so I don't have a narrower regression range.

Latest log:  http://brasstacks.mozilla.com/autologserver/showlog?file=5daf4dc4-e71b-11e1-9fa6-22000af48af0.txt.gz

You can see the full list of disabled content/media tests at https://github.com/jonallengriffin/b2gautomation/blob/master/b2gautomation/b2g.json
(Reporter)

Comment 3

7 years ago
All of the content/media tests are failing or timing out on B2G.  I'm going to disable all of them in B2G test runs, since they're blocking other tests from running.
https://hg.mozilla.org/mozilla-central/rev/bf8679d1a2f0
Assignee: nobody → jsmith
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Wrong bug.
Assignee: jsmith → nobody
Status: RESOLVED → REOPENED
Flags: in-testsuite+
Resolution: FIXED → ---
Target Milestone: mozilla19 → ---
(In reply to Ryan VanderMeulen from comment #4)
> https://hg.mozilla.org/mozilla-central/rev/bf8679d1a2f0

(In reply to Jason Smith [:jsmith] from comment #5)
> Wrong bug.

For anyone coming here for that commit from hg annotate, the correct bug number is bug 780790.
Whiteboard: [orange]
Resolving WFM any keyword:intermittent-failure bug where:
* Changed: (is less than or equal to) -3m
* Whiteboard: (contains none of the strings) random disabled marked fuzzy todo fails failing annotated time-bomb
* Whiteboard: (does not contain the string) leave open

There will inevitably be some false positives; for that (and the bugspam) I apologise, but at least this will clear out the open cruft (and thus reduce risk of mis-starring) on TBPL's annotated summary bug suggestions.

Filter on orangewfm.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.