Passing incorrect object types into any of the mozGetUserMedia needs to cleanly type check and fail gracefully on failure

RESOLVED DUPLICATE of bug 882145

Status

()

RESOLVED DUPLICATE of bug 882145
6 years ago
3 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Steps:

Call mozGetUserMedia with an incorrect object type for any of the parameters. Example:

mozGetUserMedia(1, function() {}, function() {});

Expected:

A TypeError should be thrown when an incorrect parameter is seen.

Actual:

Nasty-like error was thrown instead (unchecked exception):

Timestamp: 8/6/2012 8:40:09 PM
Error: NS_ERROR_XPC_BAD_CONVERT_JS: Could not convert JavaScript argument arg 0 [nsIDOMNavigatorUserMedia.mozGetUserMedia]
Source File: file:///C:/Users/jsmith/Documents/Camera%20API/Simple%20Scratchpad.html
Line: 19
(Reporter)

Updated

6 years ago
Whiteboard: [getUserMedia], [blocking-gum+]
(Reporter)

Updated

6 years ago
Whiteboard: [getUserMedia], [blocking-gum+] → [getUserMedia], [blocking-gum-]
Is this still correct, and if so what should we do?
backlog: --- → parking-lot
Flags: needinfo?(jib)
QA Contact: jsmith
Whiteboard: [getUserMedia], [blocking-gum-]
OBE.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jib)
Resolution: --- → DUPLICATE
Duplicate of bug: 882145
You need to log in before you can comment on or make changes to this bug.